Bug 1301674 - --setup-dns and other options is forgotten for using an external PKI
Summary: --setup-dns and other options is forgotten for using an external PKI
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Keywords: Regression, ZStream
Depends On:
Blocks: 1303059
TreeView+ depends on / blocked
 
Reported: 2016-01-25 16:25 UTC by Petr Vobornik
Modified: 2016-11-04 05:50 UTC (History)
9 users (show)

(edit)
Cause:
IPA server installation with externally signed CA certificate is split into two command runs. Options provided to the first run are stored and later restored in second run. Option '--setup-dns' was not stored in the end of the first run.

Consequence: 
Default value (false) of option '--setup-dns' was used in second run of IPA server installer. DNS server was not configured together with IPA server.

Fix:
Values of all provided options are stored between installer runs.

Result:
Second run of IPA server respects values of previously provided options.
Clone Of:
: 1303059 (view as bug list)
(edit)
Last Closed: 2016-11-04 05:50:22 UTC


Attachments (Terms of Use)
console.log (14.82 KB, text/plain)
2016-08-04 11:52 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-01-25 16:25:35 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/5556

Ticket was cloned from Red Hat Bugzilla (product ''Fedora''): [https://bugzilla.redhat.com/show_bug.cgi?id=1292099 Bug 1292099]

{{{
If I run

        ipa-server-install -n example.com -r EXAMPLE.COM --external-ca
--subject="O=example AG,C=DE" --setup-dns --forwarder ...

then it asks me get signed certificates and to run ipa-server-install again.
Quote:

        The next step is to get /root/ipa.csr signed by your CA and re-run
/usr/sbin/ipa-server-install as:
        /usr/sbin/ipa-server-install
--external-cert-file=/path/to/signed_certificate
--external-cert-file=/path/to/external_ca_certificate

If I do, then DNS is not setup. I have to add the DNS specific options again.
This is highly misleading. ipa-server-install should show *all* necessary
command line arguments to complete the second step, according to step 1.

Unfortunately the log file is gone. Did you know that ipa-server-install
overwrites its own logfiles?
}}}

Comment 1 Petr Vobornik 2016-01-25 16:30:16 UTC
This is a regression in 7.2. Second step of installation should use the options which were provided in the first step.  It does not happen and therefore DNS was not installed.

It may also lead to other issues related to non-default options, e.g. bug 1292042. 

Already fixed upstream.

Comment 10 Abhijeet Kasurde 2016-08-04 11:52:04 UTC
Verified using IPA version ::
ipa-server-4.4.0-4.el7.x86_64

Attached console.log. Marking bug as verified.

Comment 11 Abhijeet Kasurde 2016-08-04 11:52 UTC
Created attachment 1187450 [details]
console.log

Comment 13 errata-xmlrpc 2016-11-04 05:50:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.