Bug 1301743 - Adding duplicate zone sets zone name field disabled/uneditable
Adding duplicate zone sets zone name field disabled/uneditable
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.6.0
Assigned To: lgalis
Alex Newman
ui
:
: 1301745 (view as bug list)
Depends On:
Blocks: 1302837
  Show dependency treegraph
 
Reported: 2016-01-25 16:42 EST by Alex Newman
Modified: 2016-06-29 11:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1302837 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:33:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Dan Clarizio 2016-01-25 17:10:54 EST
*** Bug 1301745 has been marked as a duplicate of this bug. ***
Comment 3 Shveta 2016-01-27 14:41:24 EST
Assigning to add test case
Comment 5 CFME Bot 2016-03-16 13:05:38 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/a0803318ce04fcadb7181be7713f40ce9e966f88

commit a0803318ce04fcadb7181be7713f40ce9e966f88
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Wed Mar 9 09:02:11 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Wed Mar 16 09:33:44 2016 -0400

    Do not disable the display name when an error occur on adding a new availability zone
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1301743
    
    Do not disable the display name when an error occur on adding a new availability zone
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1301743

 app/views/ops/_zone_form.html.haml          |  2 +-
 spec/controllers/ops_settings_spec.rb       | 41 ++++++++++++++++++++++++++++-
 spec/views/ops/_zone_form.html.haml_spec.rb | 12 +++++++++
 3 files changed, 53 insertions(+), 2 deletions(-)
 create mode 100644 spec/views/ops/_zone_form.html.haml_spec.rb
Comment 6 CFME Bot 2016-03-16 13:05:42 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/a0803318ce04fcadb7181be7713f40ce9e966f88

commit a0803318ce04fcadb7181be7713f40ce9e966f88
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Wed Mar 9 09:02:11 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Wed Mar 16 09:33:44 2016 -0400

    Do not disable the display name when an error occur on adding a new availability zone
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1301743
    
    Do not disable the display name when an error occur on adding a new availability zone
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1301743

 app/views/ops/_zone_form.html.haml          |  2 +-
 spec/controllers/ops_settings_spec.rb       | 41 ++++++++++++++++++++++++++++-
 spec/views/ops/_zone_form.html.haml_spec.rb | 12 +++++++++
 3 files changed, 53 insertions(+), 2 deletions(-)
 create mode 100644 spec/views/ops/_zone_form.html.haml_spec.rb
Comment 8 Alex Newman 2016-04-11 11:33:38 EDT
5.6.0.0-beta1.20160322143549_f7ea680
Comment 9 CFME Bot 2016-04-14 17:25:38 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=fcaf4da2b7bf7fd3f1d6cac6908ed52f5ee359cf

commit fcaf4da2b7bf7fd3f1d6cac6908ed52f5ee359cf
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Wed Mar 9 09:02:11 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Thu Mar 17 08:44:15 2016 -0400

    Do not disable the display name when an error occur on adding a new availability zone
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1301743
    
    Do not disable the display name when an error occur on adding a new availability zone
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1301743
    (cherry picked from commit a080331)

 app/views/ops/_zone_form.html.haml          |  2 +-
 spec/controllers/ops_settings_spec.rb       | 41 ++++++++++++++++++++++++++++-
 spec/views/ops/_zone_form.html.haml_spec.rb | 12 +++++++++
 3 files changed, 53 insertions(+), 2 deletions(-)
 create mode 100644 spec/views/ops/_zone_form.html.haml_spec.rb
Comment 10 CFME Bot 2016-04-14 17:25:43 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=fcaf4da2b7bf7fd3f1d6cac6908ed52f5ee359cf

commit fcaf4da2b7bf7fd3f1d6cac6908ed52f5ee359cf
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Wed Mar 9 09:02:11 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Thu Mar 17 08:44:15 2016 -0400

    Do not disable the display name when an error occur on adding a new availability zone
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1301743
    
    Do not disable the display name when an error occur on adding a new availability zone
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1301743
    (cherry picked from commit a080331)

 app/views/ops/_zone_form.html.haml          |  2 +-
 spec/controllers/ops_settings_spec.rb       | 41 ++++++++++++++++++++++++++++-
 spec/views/ops/_zone_form.html.haml_spec.rb | 12 +++++++++
 3 files changed, 53 insertions(+), 2 deletions(-)
 create mode 100644 spec/views/ops/_zone_form.html.haml_spec.rb
Comment 12 errata-xmlrpc 2016-06-29 11:33:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.