Bug 1301758 - Backport fix for issue with graceful restart taking very long time sometimes
Backport fix for issue with graceful restart taking very long time sometimes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: httpd (Show other bugs)
6.7
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Web Stack Team
Petr Šplíchal
: ZStream
: 1304363 (view as bug list)
Depends On:
Blocks: 1304712
  Show dependency treegraph
 
Reported: 2016-01-25 17:48 EST by Robert Bost
Modified: 2016-05-31 21:45 EDT (History)
7 users (show)

See Also:
Fixed In Version: httpd-2.2.15-53.el6
Doc Type: Bug Fix
Doc Text:
Due to a race condition in the termination of httpd child processes during a graceful restart, a child process could exit earlier than the main httpd process expected. Consequently, the main httpd process could try to communicate with an already exited child process, which could lead to a long delay when gracefully restarting httpd. With this update, httpd has been fixed to handle the described situation correctly, it no longer tries to communicate with exited child processes, and a graceful restart is no longer delayed.
Story Points: ---
Clone Of:
: 1304712 1327624 (view as bug list)
Environment:
Last Closed: 2016-05-10 17:37:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 54852 None None None 2016-01-25 17:48 EST
Red Hat Knowledge Base (Solution) 2154791 None None None 2016-02-12 11:26 EST

  None (edit)
Description Robert Bost 2016-01-25 17:48:19 EST
Description of problem: Need backport of the fix for https://bz.apache.org/bugzilla/show_bug.cgi?id=54852 


Version-Release number of selected component (if applicable): httpd-2.2.15-47.el6_7


How reproducible: Reproduction steps are described in original BZ


Actual results: graceful restarts sometimes taking long time to complete


Expected results: graceful restart should happen fairly quickly
Comment 9 Jan Kaluža 2016-02-08 05:47:04 EST
*** Bug 1304363 has been marked as a duplicate of this bug. ***
Comment 13 errata-xmlrpc 2016-05-10 17:37:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0841.html

Note You need to log in before you can comment on or make changes to this bug.