Bug 1304712 - Backport fix for issue with graceful restart taking very long time sometimes
Backport fix for issue with graceful restart taking very long time sometimes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: httpd (Show other bugs)
6.7
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Web Stack Team
Martin Frodl
: ZStream
Depends On: 1301758
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 07:46 EST by Marcel Kolaja
Modified: 2016-03-22 11:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: httpd-2.2.15-47.el6_7.4
Doc Type: Bug Fix
Doc Text:
Due to a race condition in the termination of httpd child processes during a graceful restart, a child process could exit earlier than the main httpd process expected. Consequently, the main httpd process could try to communicate with an already exited child process, which could lead to a long delay when gracefully restarting httpd. With this update, httpd has been fixed to handle the described situation correctly, it no longer tries to communicate with exited child processes, and a graceful restart is no longer delayed.
Story Points: ---
Clone Of: 1301758
Environment:
Last Closed: 2016-03-22 11:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 54852 None None None 2016-02-04 07:46 EST

  None (edit)
Description Marcel Kolaja 2016-02-04 07:46:41 EST
This bug has been copied from bug #1301758 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 7 errata-xmlrpc 2016-03-22 11:23:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0471.html

Note You need to log in before you can comment on or make changes to this bug.