Bug 1301871 - Online Logical CPU Cores list - many entries results in corrupted display - host cannot be approved (see comment 5)
Online Logical CPU Cores list - many entries results in corrupted display - h...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
x86_64 Linux
medium Severity urgent (vote)
: ovirt-3.6.3
: ---
Assigned To: Ravi Nori
Petr Matyáš
: Regression
: 1291839 1306213 (view as bug list)
Depends On:
Blocks: RHEV_36_HTB
  Show dependency treegraph
 
Reported: 2016-01-26 03:57 EST by Ade Bradshaw
Modified: 2016-05-23 07:03 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 02:25:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
mgoldboi: planning_ack+
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
Screenshot showing list of Online CPU cores not being truncated (177.94 KB, image/png)
2016-01-26 03:57 EST, Ade Bradshaw
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52932 master MERGED webadmin: Fix display if Online Logical CPU Cores list 2016-02-04 09:20 EST
oVirt gerrit 53145 ovirt-engine-3.6 MERGED webadmin: Fix display if Online Logical CPU Cores list 2016-02-08 11:45 EST
oVirt gerrit 53232 ovirt-engine-3.6.3 MERGED webadmin: Fix display if Online Logical CPU Cores list 2016-02-08 13:57 EST
oVirt gerrit 53308 master MERGED webadmin: Fix display if Online Logical CPU Cores list 2016-02-09 12:20 EST
oVirt gerrit 53312 ovirt-engine-3.6 MERGED webadmin: Fix display if Online Logical CPU Cores list 2016-02-09 14:56 EST
oVirt gerrit 53315 ovirt-engine-3.6.3 MERGED webadmin: Fix display if Online Logical CPU Cores list 2016-02-10 06:39 EST

  None (edit)
Description Ade Bradshaw 2016-01-26 03:57:43 EST
Created attachment 1118394 [details]
Screenshot showing list of Online CPU cores not being truncated

Description of problem:
On medium/large servers (with many cores), the "Online Logical CPU Cores" entry on the Hosts General tab, corrupts the display of other information (see attached screenshot)

Version-Release number of selected component (if applicable):
3.6 beta (as of 25th January 2016)

How reproducible:
100%

Steps to Reproduce:
1. Add a HV to the cluster that has say 40 CPU cores
2. Go to the hosts tab, select the host and look at the general tab
3. The list of online CPU cores is not truncated and overwrites the other info on that tab

Actual results:
The list of online CPU cores is not truncated and overwrites the other info on that tab


Expected results:
The list is truncated and maybe a hover/pop up contains the full list

Additional info:
Comment 1 Oved Ourfali 2016-01-29 12:06:57 EST
Ravi, can you take a look?
Comment 2 Yaniv Kaul 2016-02-05 15:32:04 EST
Please move from 3.6.4 - either 3.6.5 or 3.6.3.
Comment 3 Red Hat Bugzilla Rules Engine 2016-02-09 11:41:32 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Oved Ourfali 2016-02-10 06:43:42 EST
*** Bug 1306213 has been marked as a duplicate of this bug. ***
Comment 5 Ying Cui 2016-02-14 05:08:07 EST
I have to escalate this bug because the bug 1306213 has been marked as a duplicate of this bug.

With the bug 1306213, after RHEV-H register to RHEV-M, the host can not get approve because the RHEV-M portal UI always popup the Exception caught: (TypeError) __gwt$exception: <skipped>: Cannot read property 'replace' of null, and the Approve button is disabled. 

We did not encounter this issue during RHEV 3.6 beta 3 testing, so it is a regression bug. And we can not move on because of this bug, without getting host approve and UP, we can not test storage and network relevant test cases.
Comment 6 Red Hat Bugzilla Rules Engine 2016-02-14 18:43:03 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 7 Marek Libra 2016-02-15 08:11:58 EST
*** Bug 1291839 has been marked as a duplicate of this bug. ***
Comment 8 Petr Matyáš 2016-02-18 06:51:51 EST
Verified on 3.6.3-3

Note You need to log in before you can comment on or make changes to this bug.