Bug 1301966 - postfix-2.10.1-6.el7.x86_64 component dependency is missing for ovirt-hosted-engine-setup-1.3.2.2-2.el7ev.noarch on RHEVH (20160113.0.el7ev) [NEEDINFO]
postfix-2.10.1-6.el7.x86_64 component dependency is missing for ovirt-hosted-...
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: Build (Show other bugs)
4.0
x86_64 Linux
low Severity high (vote)
: ovirt-4.0.0-beta
: 4.0
Assigned To: Douglas Schilling Landgraf
cshao
: Reopened
Depends On:
Blocks: 1335503
  Show dependency treegraph
 
Reported: 2016-01-26 08:06 EST by Nikolai Sednev
Modified: 2016-07-05 04:01 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-ng-installer-master-2016052300.iso
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 04:01:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fdeutsch: needinfo? (msivak)
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
fdeutsch: devel_ack+
cshao: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 56173 master NEW spec: Add postfix as requirement 2016-04-15 00:19 EDT
oVirt gerrit 57385 ovirt-4.0 MERGED spec: Add postfix as requirement 2016-05-17 07:27 EDT
oVirt gerrit 57386 ovirt-3.6 MERGED spec: Add postfix as requirement 2016-05-17 07:27 EDT

  None (edit)
Description Nikolai Sednev 2016-01-26 08:06:54 EST
Description of problem:
postfix-2.10.1-6.el7.x86_64 component dependency is missing for ovirt-hosted-engine-setup-1.3.2.2-2.el7ev.noarch on RHEVH (20160113.0.el7ev).

rpm -qa ovirt-hosted-engine-setup
ovirt-hosted-engine-setup-1.3.2.2-2.el7ev.noarch
rpm -qR ovirt-hosted-engine-setup | rpm -qa postfix
cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20160113.0.el7ev)

rpm -qa ovirt-hosted-engine-setup
ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch
rpm -qR ovirt-hosted-engine-setup | rpm -qa postfix
postfix-2.10.1-6.el7.x86_64
cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)


Please add postfix component as dependency for ovirt-hosted-engine-setup on RHEVH, just like it is for the RHEL7.2. 

postfix is required for the ovirt-ha-broker to be able to send emails to administrator over SMTP, in case of errors or any abnormal activity on host. SMTP being configured on host during hosted-engine --deploy phase.

Version-Release number of selected component (if applicable):
RHEL7.2:
ovirt-vmconsole-1.0.0-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
mom-0.5.1-1.el7ev.noarch
ovirt-vmconsole-host-1.0.0-1.el7ev.noarch
sanlock-3.2.4-2.el7_2.x86_64
ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.6.x86_64
ovirt-host-deploy-1.4.1-1.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.2.x86_64
ovirt-setup-lib-1.0.1-1.el7ev.noarch
vdsm-4.17.18-0.el7ev.noarch
postfix-2.10.1-6.el7.x86_64
Linux version 3.10.0-327.8.1.el7.x86_64 (mockbuild@x86-034.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Mon Jan 11 05:03:18 EST 2016

RHEVH:
ovirt-node-selinux-3.6.1-3.0.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.2-2.el7ev.noarch
ovirt-node-plugin-vdsm-0.6.1-5.el7ev.noarch
ovirt-setup-lib-1.0.1-1.el7ev.noarch
ovirt-host-deploy-1.4.1-1.el7ev.noarch
ovirt-node-branding-rhev-3.6.1-3.0.el7ev.noarch
ovirt-vmconsole-host-1.0.0-1.el7ev.noarch
ovirt-node-lib-legacy-3.6.1-3.0.el7ev.noarch
ovirt-node-lib-3.6.1-3.0.el7ev.noarch
ovirt-node-3.6.1-3.0.el7ev.noarch
ovirt-node-plugin-snmp-logic-3.6.1-3.0.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64
ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-6.el7ev.noarch
ovirt-host-deploy-offline-1.4.0-1.el7ev.x86_64
ovirt-node-plugin-snmp-3.6.1-3.0.el7ev.noarch
ovirt-node-plugin-rhn-3.6.1-3.0.el7ev.noarch
sanlock-3.2.4-1.el7.x86_64
ovirt-vmconsole-1.0.0-1.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.2.x86_64
mom-0.5.1-1.el7ev.noarch
ovirt-node-lib-config-3.6.1-3.0.el7ev.noarch
ovirt-node-plugin-cim-logic-3.6.1-3.0.el7ev.noarch
vdsm-4.17.17-0.el7ev.noarch
ovirt-node-plugin-cim-3.6.1-3.0.el7ev.noarch
Linux version 3.10.0-327.4.4.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Thu Dec 17 15:51:24 EST 2015



How reproducible:
100%

Steps to Reproduce:
1.Deploy clean RHEVH on host and search for posix to be installed.
2.
3.

Actual results:
posix component was not added as a dependency to ovirt-hosted-engine-setup on RHEVH, while it is a dependency for regular RHEL-HE deployment, this prevents email notification to be sent from ovirt-ha-broker to system administrators.

Expected results:
posix should be added to RHEVH just as it's added to RHEL as dependency of the ovirt-hosted-engine-setup component.

Additional info:
Comment 1 Sandro Bonazzola 2016-01-27 08:03:20 EST
Martin, do we really need postfix? Aren't we allowing to use external smtp server?
Comment 2 Martin Sivák 2016-01-27 08:24:57 EST
Postfix is definitely not needed. Hosted engine can use any SMTP server on network to send the email.
Comment 3 Doron Fediuck 2016-01-27 08:30:48 EST
Post fix is completely optional.
Comment 4 Nikolai Sednev 2016-01-31 07:38:40 EST
(In reply to Doron Fediuck from comment #3)
> Post fix is completely optional.

Hi Doron,
Are the error reporting through the SMTP supported for the RHEVH just as they're supported for RHEL6.x/7.x?
Comment 5 Doron Fediuck 2016-02-02 12:27:18 EST
(In reply to Nikolai Sednev from comment #4)
> (In reply to Doron Fediuck from comment #3)
> > Post fix is completely optional.
> 
> Hi Doron,
> Are the error reporting through the SMTP supported for the RHEVH just as
> they're supported for RHEL6.x/7.x?

Hi, email notifications are optional and require additional configuration. The main reporting is done to the log file(s).

Having said that, re-opening to revisit for 4.0.
Comment 6 Nikolai Sednev 2016-02-03 03:22:19 EST
(In reply to Doron Fediuck from comment #5)
> (In reply to Nikolai Sednev from comment #4)
> > (In reply to Doron Fediuck from comment #3)
> > > Post fix is completely optional.
> > 
> > Hi Doron,
> > Are the error reporting through the SMTP supported for the RHEVH just as
> > they're supported for RHEL6.x/7.x?
> 
> Hi, email notifications are optional and require additional configuration.
> The main reporting is done to the log file(s).
> 
> Having said that, re-opening to revisit for 4.0.

Hi Doron,

Shouldn't postfix dependency be removed from RHEL based ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch? 

"hosted-engine --deploy" procedure requires from customer to fill in the SMTP if it is desired, if not added during first deployment, there is no easy and user-friendly way to add SMTP later, while using "hosted-engine --deploy" procedure. If for RHEL based deployments SMTP might be added later using some manual configuration, then how should it be supported for RHEVH?

Sorry for a small off-topic, is there a Syslog server support available or planned for the hosted-engine (agent/broker)?
Comment 7 Martin Sivák 2016-02-24 09:20:07 EST
Just to answer the syslog question. The local logging of hosted engine is configured using /etc/ovirt-hosted-engine-ha/agent-log.conf and Python
provides SyslogHandler
https://docs.python.org/2/library/logging.handlers.html#sysloghandler that can be configured there.

We do not really have any example about this, but it should work. You have to do it on every host though, it is not centralized.


With regards to the postfix dependency.. if the setup is not sending any emails (and I do not think it is) then there should probably be no RPM dependency on postfix.
Comment 8 Fabian Deutsch 2016-04-15 06:48:54 EDT
pulling in postifx would add another 17MB to the image.
An increase of ~2.5%.

Moran, do we want to take this increase considering that postfix is an optional depdendency?
Users could still use MTAs on remote machines.
Comment 9 Moran Goldboim 2016-04-18 04:54:57 EDT
(In reply to Fabian Deutsch from comment #8)
> pulling in postifx would add another 17MB to the image.
> An increase of ~2.5%.
> 
> Moran, do we want to take this increase considering that postfix is an
> optional depdendency?
> Users could still use MTAs on remote machines.

my questions back to you are:
-will users will be capable to have this functionality if they desire it later on?
-what would be the impact for the user who decided to configure those configure those params on rhevh HE setup.
Comment 10 Fabian Deutsch 2016-04-18 05:30:30 EDT
(In reply to Moran Goldboim from comment #9)
> my questions back to you are:
> -will users will be capable to have this functionality if they desire it
> later on?

They can not install postfix on the host where they are currently running HE.
But they can - always - configure the host to use an MTA on a remote host.

> -what would be the impact for the user who decided to configure those
> configure those params on rhevh HE setup.

IIUIC the MTA is used to emit HA related notifications via email.
If postifx is not available on the current host, then a remote host can be configured during the HE setup.

Is this correct, Simone?
Comment 11 Martin Sivák 2016-04-18 05:49:06 EDT
Yes, this is correct. The user can configure a different SMTP server if localhost cannot be used.
Comment 12 Sandro Bonazzola 2016-05-02 06:07:08 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 14 Nikolai Sednev 2016-05-23 06:48:48 EDT
Just adding this here:
postfix-2.10.1-6.el7.x86_64 exists for ovirt-node-ng-installer-ovirt-4.0-2016051906.iso 
libvirt-client-1.2.17-13.el7_2.4.x86_64
qemu-kvm-tools-ev-2.3.0-31.el7_2.10.1.x86_64
qemu-kvm-ev-2.3.0-31.el7_2.10.1.x86_64
qemu-img-ev-2.3.0-31.el7_2.10.1.x86_64
qemu-kvm-common-ev-2.3.0-31.el7_2.10.1.x86_64
mom-0.5.3-1.1.el7.noarch
vdsm-4.17.999-1155.gitcf216a0.el7.centos.x86_64
sanlock-3.2.4-2.el7_2.x86_64
ovirt-vmconsole-host-1.0.2-0.0.master.20160517094103.git06df50a.el7.noarch
ovirt-setup-lib-1.0.2-0.0.master.20160502125738.gitf05af9e.el7.centos.noarch
ovirt-release40-4.0.0-0.3.beta1.noarch
ovirt-vmconsole-1.0.2-0.0.master.20160517094103.git06df50a.el7.noarch
ovirt-engine-sdk-python-3.6.5.1-0.1.20160507.git5fb7e0e.el7.centos.noarch
ovirt-host-deploy-1.5.0-0.1.alpha1.el7.centos.noarch
ovirt-hosted-engine-setup-2.0.0-0.1.beta1.el7.centos.noarch
ovirt-release-host-node-4.0.0-0.3.beta1.el7.noarch
ovirt-hosted-engine-ha-2.0.0-0.1.beta1.el7.centos.noarch
ovirt-node-ng-image-update-placeholder-4.0.0-0.3.beta1.el7.noarch
CentOS Linux release 7.2.1511 (Core) 
Linux 3.10.0-327.18.2.el7.x86_64 #1 SMP Thu May 12 11:03:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Linux version 3.10.0-327.18.2.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Thu May 12 11:03:55 UTC 2016
Comment 16 cshao 2016-06-02 06:27:58 EDT
Test version:
rhev-hypervisor7-ng-4.0-20160527.0
imgbased-0.7.0-0.1.el7ev.noarch

postfix and mailx are exist on above build, and deploy hosted engine can successful.
# rpm -qa | grep postfix
postfix-2.10.1-6.el7.x86_64

# rpm -qa | grep mailx
mailx-12.5-12.el7_0.x86_64

So the bug is fixed, change bug status to VERIFIED.
Comment 17 Fabian Deutsch 2016-06-03 14:35:22 EDT
Martin, did you say that you wanted to remove "local MTA" support?
Comment 18 Sandro Bonazzola 2016-07-05 04:01:07 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.