Bug 1302098 - Incorrect Next Sync date calculation in weekly Sync Plan
Incorrect Next Sync date calculation in weekly Sync Plan
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.5
Unspecified Linux
unspecified Severity medium (vote)
: 6.2.5
: --
Assigned To: Walden Raines
Peter Ondrejka
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1396647 1463696 1463301
  Show dependency treegraph
 
Reported: 2016-01-26 13:49 EST by Matt Ruzicka
Modified: 2017-06-21 10:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: tfm-rubygem-katello-3.0.0.86-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1396647 1463696 (view as bug list)
Environment:
Last Closed: 2016-12-12 12:10:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16035 None None None 2016-08-09 15:05 EDT

  None (edit)
Description Matt Ruzicka 2016-01-26 13:49:57 EST
Description of problem:

Setting the Start Date for some weekly Sync Plan schedules results in an incorrect date calculation that causes the Next Sync date to skip a week.

Issue appears to be linked at at one specific date.

Version-Release number of selected component (if applicable):

Satellite 6.1.5 at least

How reproducible: Appears to be every time


Steps to Reproduce:
1. Create weekly Sync Plan
2. Set Start Date to Jan 22, 2016 (may be date specific)
3. Next Sync date should show Feb 5, 2016 (skipping Jan 29, 2016)

Actual results:

Next Sync date reports Feb 5, 2016

Expected results:

Next Sync should be Jan 29, 2016


Additional info:

Customer reported this in their environment and it was also reproduced in house with the start date Jan 22, 2016.  Using the start date Jan 25, 2016 /did not/ reproduce the error.
Comment 1 Matt Ruzicka 2016-02-02 16:29:30 EST
I heard from the on site DEE that while the Next Sync date displayed Feb 5, the since actually execute and run on Jan 29 as would normally be expected.

In other words, the logic seems to work (e.g., every Friday), just the display of the next date the sync will run was in error (e.g., the following Friday).
Comment 10 Walden Raines 2016-08-09 14:41:40 EDT
Created redmine issue http://projects.theforeman.org/issues/16035 from this bug
Comment 11 Walden Raines 2016-08-09 15:14:34 EDT
PR: https://github.com/Katello/katello/pull/6238
Comment 12 Bryan Kearney 2016-08-09 16:12:21 EDT
Upstream bug component is Content Management
Comment 13 Bryan Kearney 2016-08-22 14:12:18 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/16035 has been closed
Comment 14 Matt Ruzicka 2016-08-22 14:38:09 EDT
Thanks for the update Bryan.  Would we expect to see this in 6.2.2 or will we need to wait for 6.3 since it landed in the current foreman?
Comment 18 Peter Ondrejka 2016-10-21 05:29:47 EDT
Verified in Sat 6 snap 5. Next sync is calculated correctly for weekly sync in case the start date is less than a week in past from the current day.
Comment 19 Peter Ondrejka 2016-12-01 07:27:45 EST
Verified in 6.2.5
Comment 21 errata-xmlrpc 2016-12-12 12:10:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2940

Note You need to log in before you can comment on or make changes to this bug.