Bug 1302139 - VM permanently tries to read /dev/shm/lttng-ust-wait-5 saturating logs.
VM permanently tries to read /dev/shm/lttng-ust-wait-5 saturating logs.
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph (Show other bugs)
1.3.1
All Linux
medium Severity medium
: rc
: 1.3.2
Assigned To: Brad Hubbard
ceph-qe-bugs
: CodeChange, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 17:13 EST by Mike Hackett
Modified: 2016-02-29 09:45 EST (History)
7 users (show)

See Also:
Fixed In Version: RHEL: ceph-0.94.5-8.el7cp Ubuntu: ceph_0.94.5-5redhat1trusty
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:45:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1432644 None None None 2016-02-03 17:56 EST
Ceph Project Bug Tracker 13274 None None None 2016-02-03 18:04 EST
Ceph Project Bug Tracker 14520 None None None 2016-01-26 17:13 EST

  None (edit)
Description Mike Hackett 2016-01-26 17:13:09 EST
Description of problem:

Ubuntu 14.04
Ceph 94.5-1trusty - But liblttng is also packaged in RHCS 1.3.1 so downstream is susceptible to this as well.
liblttng-ust0
libvert
Bug is open with Canonical: https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1432644/

Logs are constantly spammed with:
[4220163.899438] type=1400 audit(1447230173.207:7763726): apparmor="DENIED" operation="open" profile="libvirt-" name="/run/shm/lttng-ust-wait-5" pid=69948 comm="qemu-system-x86" requested_mask="r" denied_mask="r" fsuid=111 ouid=0

VM permanently tries to read /dev/shm/lttng-ust-wait-5

When used with enforced apparmor profile, this results in logs filled with denied messages.
As I understand it, liblttng is here to allow tracing / debugging in python (not sure). Maybe virt-manager shouldn't be shipped with debugging mode enabled by default, or maybe it is a perfectly legitimate feature and the apparmor profile should be updated.

lttng is disabled in Infernalis by default, but need to address issue being seen in Hammer.

Upstream bug ID: http://tracker.ceph.com/issues/14520
Comment 2 Josh Durgin 2016-01-26 17:29:48 EST
Upstream ceph commits 5d204db..a81bcf7 (in the hammer branch) fix this.
Comment 3 Brad Hubbard 2016-02-03 00:38:28 EST
Josh, Is a81bcf7 relevant to this bug?
Comment 4 Josh Durgin 2016-02-03 00:57:29 EST
(In reply to Brad Hubbard from comment #3)
> Josh, Is a81bcf7 relevant to this bug?

Yes, it's needed since d02beff1cf7650fe6e57cdafe64dcbee2631ed52 introduces the Singleton that it fixes.
Comment 5 Brad Hubbard 2016-02-03 01:05:20 EST
My bad, sorry Josh.
Comment 6 Boris Ranto 2016-02-03 18:02:34 EST
You will probably need to back-port only the following patch:

https://github.com/dillaman/ceph/commit/e53d66e42b1c3aea47832f7e8983284ec45d9efa

The rest of the upstream PR should already be covered by bz 1304455.
Comment 14 monti lawrence 2016-02-17 13:51:05 EST
Moving to VERIFIED per kdreyer in 2/17 PM call.
Comment 16 errata-xmlrpc 2016-02-29 09:45:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0313

Note You need to log in before you can comment on or make changes to this bug.