Bug 1302190 - [abrt] dnf: i18n.py:110:ucd_input:UnicodeDecodeError: 'utf-8' codec can't decode byte 0xd0 in position 0: invalid continuation byte
[abrt] dnf: i18n.py:110:ucd_input:UnicodeDecodeError: 'utf-8' codec can't dec...
Status: CLOSED DUPLICATE of bug 1295090
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
low Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6f163d0b2ebc021f67120b19ad6...
: i18n, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 00:52 EST by Oleg R. Dubovko
Modified: 2016-08-01 08:44 EDT (History)
9 users (show)

See Also:
Fixed In Version: dnf-1.1.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 08:44:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (90.15 KB, text/plain)
2016-01-27 00:53 EST, Oleg R. Dubovko
no flags Details
File: backtrace (1.22 KB, text/plain)
2016-01-27 00:53 EST, Oleg R. Dubovko
no flags Details
File: dnf-makecache.log (3.26 MB, text/plain)
2016-01-27 00:53 EST, Oleg R. Dubovko
no flags Details
File: environ (2.08 KB, text/plain)
2016-01-27 00:53 EST, Oleg R. Dubovko
no flags Details

  None (edit)
Description Oleg R. Dubovko 2016-01-27 00:52:55 EST
Version-Release number of selected component:
dnf-1.1.5-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /usr/bin/dnf install libusb libusb-devel pyusb libgudev python3-pyudev python2-pyudev
executable:     /usr/bin/dnf
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
i18n.py:110:ucd_input:UnicodeDecodeError: 'utf-8' codec can't decode byte 0xd0 in position 0: invalid continuation byte

Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 149, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 200, in do_transaction
    if self.conf.assumeno or not self.output.userconfirm():
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 631, in userconfirm
    choice = dnf.i18n.ucd_input(msg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 110, in ucd_input
    return dnf.pycomp.raw_input()
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xd0 in position 0: invalid continuation byte

Local variables in innermost frame:
ucstring: 'Продолжить? [д/Н]: '
Comment 1 Oleg R. Dubovko 2016-01-27 00:53:02 EST
Created attachment 1118679 [details]
File: _var_log_dnf.log
Comment 2 Oleg R. Dubovko 2016-01-27 00:53:04 EST
Created attachment 1118680 [details]
File: backtrace
Comment 3 Oleg R. Dubovko 2016-01-27 00:53:23 EST
Created attachment 1118681 [details]
File: dnf-makecache.log
Comment 4 Oleg R. Dubovko 2016-01-27 00:53:24 EST
Created attachment 1118682 [details]
File: environ
Comment 5 Michal Luscon 2016-02-01 07:33:07 EST
What type of terminal do you use? This crash happened after the confirmation of transaction, right?
Comment 6 Aleksandr Kalashnikov 2016-04-11 23:18:31 EDT
(In reply to Michal Luscon from comment #5)
> What type of terminal do you use? This crash happened after the confirmation
> of transaction, right?

Same problem:
[root@beta ~]# dnf update
...
Transaction Summary
================================================================================
Install   3 Packages
Upgrade  33 Packages
Remove    3 Packages

Total download size: 68 M
Is this ok [y/N]: y
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_mai                                                                         n
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 149, in resolvin                                                                         g
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 200, in do_transa                                                                         ction
    if self.conf.assumeno or not self.output.userconfirm():
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 631, in userco                                                                         nfirm
    choice = dnf.i18n.ucd_input(msg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 110, in ucd_input
    return dnf.pycomp.raw_input()
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xd0 in position 0: invalid                                                                          continuation byte

Fedora Server 23 (upgraded from 21)
Comment 7 Vlad 2016-05-30 06:46:17 EDT
Have the same issue while installing mysql server on Fedora 23.

Python version: Python 3.4.3
Terminal: guake

Steps to reproduce
1. Download MySQL Yum Repository for Fedora 23 (http://dev.mysql.com/downloads/repo/yum/)
2. dnf update
3. dnf install mysql-community-server-5.7.12-1.fc23.x86_64

Result:
Downloading Packages:
(1/6): mecab-0.996-1.fc23.3.x86_64.rpm                                                                                                                                               623 kB/s | 393 kB     00:00    
(2/6): mecab-ipadic-2.7.0.20070801-11.fc23.1.x86_64.rpm                                                                                                                              1.3 MB/s |  11 MB     00:08    
(3/6): mysql-community-common-5.7.12-1.fc23.x86_64.rpm                                                                                                                               924 kB/s | 275 kB     00:00    
(4/6): mysql-community-libs-5.7.12-1.fc23.x86_64.rpm                                                                                                                                 1.7 MB/s | 2.1 MB     00:01    
(5/6): mysql-community-client-5.7.12-1.fc23.x86_64.rpm                                                                                                                               1.1 MB/s |  24 MB     00:21    
(6/6): mysql-community-server-5.7.12-1.fc23.x86_64.rpm                                                                                                                               1.6 MB/s | 114 MB     01:12    
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                2.0 MB/s | 151 MB     01:14     
warning: /var/cache/dnf/mysql57-community-2f15c0a5416e0077/packages/mysql-community-server-5.7.12-1.fc23.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
Importing GPG key 0x5072E1F5:
 Userid     : "MySQL Release Engineering <mysql-build@oss.oracle.com>"
 Fingerprint: A4A9 4068 76FC BD3C 4567 70C8 8C71 8D3B 5072 E1F5
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
Is this ok [y/N]: y
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Traceback (most recent call last):
  File "/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 149, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 220, in do_transaction
    self.gpgsigcheck(downloadpkgs)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 258, in gpgsigcheck
    self.getKeyForPackage(po, fn)
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 1865, in getKeyForPackage
    rc = askcb(po, info.userid, info.short_id)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 257, in <lambda>
    fn = lambda x, y, z: self.output.userconfirm()
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 631, in userconfirm
    choice = dnf.i18n.ucd_input(msg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 110, in ucd_input
    return dnf.pycomp.raw_input()
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xd0 in position 0: invalid continuation byte
[root@fedora-23 tester]# mcedit /usr/lib/python3.4/site-packages/dnf/i18n.py
Comment 8 Fedora Admin XMLRPC Client 2016-07-08 05:39:16 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Štěpán Smetana 2016-08-01 08:44:12 EDT
Works for me.
Should be fixed in dnf-1.1.9 (Take a look at this commit https://github.com/rpm-software-management/dnf/commit/93159e360f0b6150e598bba783e22ca113201a40)
In case reopen this bug and provide more info.
Thanks

*** This bug has been marked as a duplicate of bug 1295090 ***

Note You need to log in before you can comment on or make changes to this bug.