Bug 130220 - Nautilus uses catalogue view by default
Nautilus uses catalogue view by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 130463 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-18 04:57 EDT by Douglas Furlong
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 04:55:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Furlong 2004-08-18 04:57:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
After upgrading to the latest version of nautilus on my FC3 Test1
machine, when using nautilus in it's spacial view it defaults to the
Catalogue view ignoring the users preference setting wich is set to Icon.

It seems to also at times, this also applies to locations already
browsed to in the past, so not just a matter of picking up the
pre-defined default, but ignoring the previously used method as well.

Let me know if any testing is required.

Douglas

Version-Release number of selected component (if applicable):
nautilus-2.7.2-1

How reproducible:
Always

Steps to Reproduce:
1. Browse to a location using nautilus in spacial mode.
2.
3.
    

Actual Results:  Uses the catalogue view.

Expected Results:  use the default view method of Icon, or use a
per-foulder configured default.

Additional info:
Comment 1 Tim Waugh 2004-08-18 05:30:09 EDT
Before now I've even had 'Computer' fail to display because it
couldn't use the catalogue view. :-)  I had to remove gthumb first.
Comment 2 Gerry Tool 2004-08-18 10:33:05 EDT
Neither Computer nor Start Here are displayable.  They throw a View
Failed dialog that says

The Catalog view encountered an error while starting up.

The location cannot be displayed with this viewer.

Since they can't be viewed, the view preference can't be set.
Comment 3 sangu 2004-08-19 02:05:16 EDT
Excute "rpm -e gthumb", this problems disappear.
Comment 4 sangu 2004-08-19 02:07:41 EDT
I am Sorry about my mistake posting.
Comment 5 Douglas Furlong 2004-08-19 05:16:13 EDT
Thanks for the suggestion with regards to gthumb. Does that mean this
is a problem with gthumb and should be re-assigned, if this is the
case, how would one go about doing it?

I unfortunatley use gthumb so removing it is far from ideal for me.

Doug
Comment 6 Tim Waugh 2004-08-19 05:18:36 EDT
CC'ing gthumb maintainer for input.
Comment 7 Michel Alexandre Salim 2004-08-19 08:55:20 EDT
As a temporary workaround, deleting
/usr/lib/bonobo/servers/GNOME_GThumb_CatalogView.server works, by the way.
Comment 8 Brian Millett 2004-08-20 19:37:16 EDT
same problem.  Removing the
/usr/lib/bonobo/servers/GNOME_GThumb_CatalogView.server helps.
Comment 9 Daniel Malmgren 2004-08-23 11:19:43 EDT
*** Bug 130463 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Malmgren 2004-08-23 11:21:21 EDT
This is in gnome bugzilla as well.

http://bugzilla.gnome.org/show_bug.cgi?id=150357
Comment 11 Alexander Larsson 2004-08-26 04:55:52 EDT
This is fixed in nautilus 2.7.4-2.
Comment 12 Eric Mailloux 2005-02-17 01:45:50 EST
I delete the .nautilus directory in my profile as root an log back in
my account. Quick and kick restore to default setting :)

In general nautilus does not remember well setting like these, as well
as windows length et height !!!

May be this probleme is a Nautilus prob. And windows things is a gnome
prob.

Eric
Comment 13 Eric Mailloux 2005-02-17 01:47:08 EST
I try before editing the preference file by hand without success 

Note You need to log in before you can comment on or make changes to this bug.