Bug 1302205 - Improve error message for unsupported clients
Improve error message for unsupported clients
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Atin Mukherjee
: Triaged
Depends On:
Blocks: 1302521 1305735
  Show dependency treegraph
 
Reported: 2016-01-27 02:12 EST by Atin Mukherjee
Modified: 2016-06-16 09:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1302521 1305735 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:55:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2016-01-27 02:12:34 EST
Description of problem:

When a volume set is executed and if there are already connected clients which are incompatible w.r.t op-version the error message doesn't point out which first client needs to be upgraded first.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-01-27 02:13:36 EST
REVIEW: http://review.gluster.org/11831 (glusterd: improve error logs for unsupported clients) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Vijay Bellur 2016-01-27 22:50:53 EST
COMMIT: http://review.gluster.org/11831 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit fd16186b403e38763b1d0b39c8c7ce14ffc508ba
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Wed Aug 5 16:02:49 2015 +0530

    glusterd: improve error logs for unsupported clients
    
    Change-Id: I90be46a7b25cc3efd0e61c9a145852e9027f5f64
    BUG: 1302205
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/11831
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Niels de Vos 2016-06-16 09:55:37 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.