Bug 1305735 - Improve error message for unsupported clients
Summary: Improve error message for unsupported clients
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: RHGS 3.1.3
Assignee: Atin Mukherjee
QA Contact: Byreddy
URL:
Whiteboard:
Depends On: 1302205
Blocks: 1299184 1302521
TreeView+ depends on / blocked
 
Reported: 2016-02-09 03:53 UTC by Atin Mukherjee
Modified: 2016-09-17 16:44 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.9-1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1302205
Environment:
Last Closed: 2016-06-23 05:07:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1240 0 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 Update 3 2016-06-23 08:51:28 UTC

Description Atin Mukherjee 2016-02-09 03:53:21 UTC
+++ This bug was initially created as a clone of Bug #1302205 +++

Description of problem:

When a volume set is executed and if there are already connected clients which are incompatible w.r.t op-version the error message doesn't point out which first client needs to be upgraded first.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-01-27 02:13:36 EST ---

REVIEW: http://review.gluster.org/11831 (glusterd: improve error logs for unsupported clients) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-27 22:50:53 EST ---

COMMIT: http://review.gluster.org/11831 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit fd16186b403e38763b1d0b39c8c7ce14ffc508ba
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Wed Aug 5 16:02:49 2015 +0530

    glusterd: improve error logs for unsupported clients
    
    Change-Id: I90be46a7b25cc3efd0e61c9a145852e9027f5f64
    BUG: 1302205
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/11831
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Atin Mukherjee 2016-03-22 12:01:46 UTC
The fix is now available in rhgs-3.1.3 branch, hence moving the state to Modified.

Comment 5 Byreddy 2016-04-06 05:55:08 UTC
Verified this bug using the build "glusterfs-3.7.9-1"


Fix is working properly, when volume is mounted on unsupported clients and volume set was done, it will through error message saying which client need to be update first.


#gluster volume set  Dis performance.readdir-ahead off
volume set: failed: One of the client 10.70.37.76:1023 is running with op-version 30703 and doesn't support the required op-version 30707. This client needs to be upgraded or disconnected before running this command again


with this details, moving bug to next state.

Comment 7 errata-xmlrpc 2016-06-23 05:07:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240


Note You need to log in before you can comment on or make changes to this bug.