Bug 1302216 - dnf: missing information about dependency problems
dnf: missing information about dependency problems
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 03:33 EST by Jan ONDREJ
Modified: 2016-02-22 07:44 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 08:21:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2016-01-27 03:33:52 EST
Description of problem:
dnf does not dislpay, which packages are required to solve dependency problems.

Version-Release number of selected component (if applicable):
dnf-1.1.6-1.fc23.noarch
libsolv-0.6.14-7.fc23.x86_64

How reproducible:
always today, until python2-configargparse will be in stable

Steps to Reproduce:
1. you need to have some broken dependency packages installed, for today it's letsencrypt
2. dnf update -y -d8 -v -v -v --debugsolver

Actual results:
(short version, but no info also with debug/verbose flags too
Last metadata expiration check performed 0:00:00 ago on Wed Jan 27 09:27:29 2016.
Dependencies resolved.
================================================================================
 Package                   Arch         Version             Repository     Size
================================================================================
Skipping packages with broken dependencies:
 letsencrypt               noarch       0.2.0-4.fc23        updates        23 k
 python2-letsencrypt       noarch       0.2.0-4.fc23        updates       293 k

Transaction Summary
================================================================================
Skip  2 Packages

Nothing to do.
Complete!

Expected results:
information, that python2-configargparse-0.10 is required for letsencrypt-0.2.

Additional info:
Comment 1 Remi Collet 2016-01-27 04:45:23 EST
same issue, thanks to yum-deprecated I can the info

Error: Package: python2-letsencrypt-0.2.0-4.fc23.noarch (updates)
           Requires: python2-configargparse >= 0.10.0
           Installed: python2-configargparse-0.9.3-3.fc23.noarch (installed)
               python2-configargparse = 0.9.3-3.fc23
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Really missing.
Comment 2 Remi Collet 2016-01-27 04:46:12 EST
$ dnf update --best
Error: nothing provides python2-configargparse >= 0.10.0 needed by python2-letsencrypt-0.2.0-4.fc23.noarch.
nothing provides python2-configargparse >= 0.10.0 needed by python2-letsencrypt-0.2.0-4.fc23.noarch
(try to add '--allowerasing' to command line to replace conflicting packages)


Seems better
Comment 4 Michal Domonkos 2016-02-01 08:21:37 EST
This is actually by design.  We don't want to clutter the output with information that's not necessarily relevant.  Knowing the technical reason for skipping in this case is only useful if one wants to manually resolve it -- which we don't assume by default, as the update command just silently skips over such broken deps anyway (as mentioned in the man page).

When using --best, however, the missing dependency becomes the reason for the whole transaction to fail, in which case showing the exact reason is appropriate.
Comment 5 Michal Domonkos 2016-02-22 07:44:53 EST
*** Bug 1309408 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.