Bug 1309408 - [RFE] Add docs that --best is showing more details on broken package dependencies
[RFE] Add docs that --best is showing more details on broken package dependen...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 12:35 EST by Christian Stadelmann
Modified: 2016-04-13 03:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-1.1.8-1.fc24 dnf-1.1.8-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 03:22:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2016-02-17 12:35:27 EST
Description of problem:
I like the fact that dnf dropped yums --skip-broken flag but skips broken packages by default and tells the user that it did. It would be nice to get more details on broken dependencies to fix those packages.

Version-Release number of selected component (if applicable):
dnf-1.1.6-2.fc23.noarch
rpm-4.13.0-0.rc1.11.fc23.x86_64
librepo-1.7.16-2.fc23.x86_64
libsolv-0.6.14-7.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. try to upgrade to a package with broken dependencies
2. watch dnf output

Actual results:
dnf lists packages skipped for upgrade due to broken dependencies

Expected results:
More info on why dependency is broken. Perhaps through an additional command line flag, to prevent unnecessary output. Or only when specifying `--verbose` to dnf.

Additional info:
I searched the documentation and couldn't find such a flag. Maybe it already exists but I don't know that.
I know of `--depsolver`, but it doesn't include this info on broken dependencies as far as I can tell.
Using `--allowerasing` can help, but usually doesn't.
Manually querying all package dependencies is possible but hard to do.
Running `dnf repoclosure` doesn't find this broken dependency (I don't know why and I can't find out why).
Comment 1 Michal Domonkos 2016-02-22 07:44:53 EST

*** This bug has been marked as a duplicate of bug 1302216 ***
Comment 2 Honza Silhan 2016-02-22 07:45:32 EST
here [1] is the `--best` option use case documented.

[1] http://dnf.readthedocs.org/en/latest/user_faq.html#why-are-dnf-check-update-packages-not-marked-for-upgrade-in-the-following-dnf-upgrade
Comment 3 Christian Stadelmann 2016-02-22 08:21:59 EST
Ok, so since this was not the first bug report opened and this feature I requested before is already implemented, it looks more like an issue for users to find it. In my case I searched `man dnf` for `broken` or `broken dependencies`. I guess this is what the man page should state:

Current text:
Try the best available package versions in transactions. Specifically  during  dnf upgrade, which by default skips over updates that can not be installed for  dependency reasons, the switch forces DNF to only consider the latest packages and possibly fail giving a reason why the latest version can not be installed.

Proposed text (note that English is not my first language so corrections are welcome):
Try the best available package versions in transactions. Specifically  during  dnf upgrade, which by default skips over updates that can not be installed for  dependency reasons, the switch forces DNF to only consider the latest packages. When running into packages with broken dependencies, DNF will fail giving a reason why the latest version can not be installed.
Comment 4 Honza Silhan 2016-03-07 07:10:50 EST
PR: https://github.com/rpm-software-management/dnf/pull/453
Comment 5 Mike McCune 2016-03-28 19:16:15 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Fedora Update System 2016-04-06 10:39:11 EDT
dnf-plugins-core-0.1.20-1.fc24 dnf-1.1.8-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5dae5d2add
Comment 7 Fedora Update System 2016-04-07 06:02:27 EDT
dnf-1.1.8-1.fc23 dnf-plugins-core-0.1.20-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ddeabfcfe6
Comment 8 Fedora Update System 2016-04-07 12:54:37 EDT
dnf-1.1.8-1.fc24, dnf-plugins-core-0.1.20-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5dae5d2add
Comment 9 Fedora Update System 2016-04-08 12:59:28 EDT
dnf-1.1.8-1.fc24, dnf-plugins-core-0.1.20-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-04-08 16:51:46 EDT
dnf-1.1.8-1.fc23, dnf-plugins-core-0.1.20-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ddeabfcfe6
Comment 11 Fedora Update System 2016-04-13 03:21:52 EDT
dnf-1.1.8-1.fc23, dnf-plugins-core-0.1.20-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.