Bug 1302257 - [tiering]: Quota object limits not adhered to, in a tiered volume
[tiering]: Quota object limits not adhered to, in a tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
All Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Manikandan
: Triaged, ZStream
Depends On: 1300307
Blocks: 1306138
  Show dependency treegraph
 
Reported: 2016-01-27 05:14 EST by Manikandan
Modified: 2016-06-16 09:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300307
: 1306138 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:56:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-27 05:16:43 EST
REVIEW: http://review.gluster.org/13299 (dht/quota : heal the limit_objects_key xattr needed for inode-quota) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2016-01-27 14:33:44 EST
REVIEW: http://review.gluster.org/13299 (dht/quota : heal the limit_objects_key xattr needed for inode-quota) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Vijay Bellur 2016-01-28 00:33:01 EST
REVIEW: http://review.gluster.org/13299 (dht/quota : heal the limit_objects_key xattr needed for inode-quota) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 4 Vijay Bellur 2016-02-01 05:43:43 EST
REVIEW: http://review.gluster.org/13299 (dht/quota : heal the limit_objects_key xattr needed for inode-quota) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 5 Vijay Bellur 2016-02-02 07:20:05 EST
REVIEW: http://review.gluster.org/13299 (dht/quota : heal the limit_objects_key xattr needed for inode-quota) posted (#5) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 6 Vijay Bellur 2016-02-09 08:08:32 EST
REVIEW: http://review.gluster.org/13299 (dht/quota : heal the limit_objects_key xattr needed for inode-quota) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 7 Vijay Bellur 2016-02-10 01:34:23 EST
REVIEW: http://review.gluster.org/13299 (dht/quota : heal the limit_objects_key xattr needed for inode-quota) posted (#7) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 8 Vijay Bellur 2016-02-11 00:21:34 EST
COMMIT: http://review.gluster.org/13299 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit acfb402414ec4a9ab8c9f9d4fead6b9141c2e934
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Wed Jan 27 14:56:33 2016 +0530

    dht/quota : heal the limit_objects_key xattr needed for inode-quota
    
    Whenever a new brick is added, quota related xattr's
    should be healed but currently, the xattr
    "quota.limit-objects.<suffix>" needed for inode-quota is
    not being healed.
    The patch fixes this issue.
    
    Change-Id: I1e7b229126f7b058642bbc3fb5c109bfd8925325
    BUG: 1302257
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13299
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 9 Niels de Vos 2016-06-16 09:56:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.