Bug 1306138 - [tiering]: Quota object limits not adhered to, in a tiered volume
[tiering]: Quota object limits not adhered to, in a tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.7
All Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Manikandan
: Triaged, ZStream
Depends On: 1300307 1302257
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 01:51 EST by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302257
Environment:
Last Closed: 2016-04-19 03:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-10 01:54:56 EST
REVIEW: http://review.gluster.org/13418 (dht/quota : heal the limit_objects_key xattr needed for inode-quota) posted (#2) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2016-02-11 00:22:33 EST
COMMIT: http://review.gluster.org/13418 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 519b097548330bf90cc491d1b95ea45e2467e505
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Wed Jan 27 14:56:33 2016 +0530

    dht/quota : heal the limit_objects_key xattr needed for inode-quota
    
    Whenever a new brick is added, quota related xattr's
    should be healed but currently, the xattr
    "quota.limit-objects.<suffix>" needed for inode-quota is
    not being healed.
    The patch fixes this issue.
    
            Backport of http://review.gluster.org/#/c/13299/
    
    > Change-Id: I1e7b229126f7b058642bbc3fb5c109bfd8925325
    > BUG: 1302257
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    
    Change-Id: I22fbbc30fbc0788a7cf80671c1f3e2a80c9e65e8
    BUG: 1306138
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13418
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Kaushal 2016-04-19 03:25:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.