Bug 1302277 - Wrong XML output for Volume Options
Wrong XML output for Volume Options
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Aravinda VK
: Triaged
Depends On:
Blocks: 1357766 1357767
  Show dependency treegraph
 
Reported: 2016-01-27 06:00 EST by Aravinda VK
Modified: 2017-03-27 14:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1357766 1357767 (view as bug list)
Environment:
Last Closed: 2017-03-27 14:15:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2016-01-27 06:00:03 EST
Description of problem:
gluster volume get <VOLNAME> all --xml returns wrong XML format

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Always

Steps to Reproduce:
1. Run gluster volume get <VOLNAME> all --xml

Actual results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volGetopts>
    <count>258</count>
    <Option>cluster.lookup-unhashed</Option>
    <Value>on</Value>
    <Option>cluster.lookup-optimize</Option>
    <Value>off</Value>
    <Option>cluster.min-free-disk</Option>
    <Value>10%</Value>
    <Option>cluster.min-free-inodes</Option>
    <Value>5%</Value>


Expected results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volGetopts>
    <count>258</count>
    <volGetopt>
        <Option>cluster.lookup-unhashed</Option>
        <Value>on</Value>
    </volGetopt>
    <volGetopt>
        <Option>cluster.lookup-optimize</Option>
        <Value>off</Value>
    </volGetopt>
    <volGetopt>
        <Option>cluster.min-free-disk</Option>
        <Value>10%</Value>
    </volGetopt>
    <volGetopt>
        <Option>cluster.min-free-inodes</Option>
        <Value>5%</Value>
    </volGetopt>


Additional info:
Comment 1 Vijay Bellur 2016-07-15 09:28:14 EDT
REVIEW: http://review.gluster.org/14931 (cli/xml: Fix wrong XML format in volume get command) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2016-07-16 13:54:17 EDT
REVIEW: http://review.gluster.org/14931 (cli/xml: Fix wrong XML format in volume get command) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 3 Vijay Bellur 2016-07-18 08:00:25 EDT
COMMIT: http://review.gluster.org/14931 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit bc0b106f0ae8ecd336c7689917e46bc2685603c8
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Jul 15 18:49:32 2016 +0530

    cli/xml: Fix wrong XML format in volume get command
    
    Without this Patch,
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volGetopts>
        <count>258</count>
        <Option>cluster.lookup-unhashed</Option>
        <Value>on</Value>
        <Option>cluster.lookup-optimize</Option>
        <Value>off</Value>
        <Option>cluster.min-free-disk</Option>
        <Value>10%</Value>
        <Option>cluster.min-free-inodes</Option>
        <Value>5%</Value>...
    
    With this patch,
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volGetopts>
        <count>258</count>
        <Opt>
            <Option>cluster.lookup-unhashed</Option>
            <Value>on</Value>
        </Opt>
        <Opt>
            <Option>cluster.lookup-optimize</Option>
            <Value>off</Value>
        </Opt>
        <Opt>
            <Option>cluster.min-free-disk</Option>
            <Value>10%</Value>
        </Opt>
        <Opt>
            <Option>cluster.min-free-inodes</Option>
            <Value>5%</Value>
        </Opt>...
    
    BUG: 1302277
    Change-Id: I6c5a040f659f2244ddcd47c57882b4f300cbe52f
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/14931
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 4 Shyamsundar 2017-03-27 14:15:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.