Bug 1357766 - Wrong XML output for Volume Options
Summary: Wrong XML output for Volume Options
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: 3.7.13
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1302277 1357767
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 06:16 UTC by Aravinda VK
Modified: 2016-08-02 07:24 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.14
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1302277
Environment:
Last Closed: 2016-08-02 07:24:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-07-19 06:16:44 UTC
+++ This bug was initially created as a clone of Bug #1302277 +++

Description of problem:
gluster volume get <VOLNAME> all --xml returns wrong XML format

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Always

Steps to Reproduce:
1. Run gluster volume get <VOLNAME> all --xml

Actual results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volGetopts>
    <count>258</count>
    <Option>cluster.lookup-unhashed</Option>
    <Value>on</Value>
    <Option>cluster.lookup-optimize</Option>
    <Value>off</Value>
    <Option>cluster.min-free-disk</Option>
    <Value>10%</Value>
    <Option>cluster.min-free-inodes</Option>
    <Value>5%</Value>


Expected results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volGetopts>
    <count>258</count>
    <volGetopt>
        <Option>cluster.lookup-unhashed</Option>
        <Value>on</Value>
    </volGetopt>
    <volGetopt>
        <Option>cluster.lookup-optimize</Option>
        <Value>off</Value>
    </volGetopt>
    <volGetopt>
        <Option>cluster.min-free-disk</Option>
        <Value>10%</Value>
    </volGetopt>
    <volGetopt>
        <Option>cluster.min-free-inodes</Option>
        <Value>5%</Value>
    </volGetopt>


Additional info:

--- Additional comment from Vijay Bellur on 2016-07-15 09:28:14 EDT ---

REVIEW: http://review.gluster.org/14931 (cli/xml: Fix wrong XML format in volume get command) posted (#1) for review on master by Aravinda VK (avishwan)

--- Additional comment from Vijay Bellur on 2016-07-16 13:54:17 EDT ---

REVIEW: http://review.gluster.org/14931 (cli/xml: Fix wrong XML format in volume get command) posted (#2) for review on master by Aravinda VK (avishwan)

--- Additional comment from Vijay Bellur on 2016-07-18 08:00:25 EDT ---

COMMIT: http://review.gluster.org/14931 committed in master by Jeff Darcy (jdarcy) 
------
commit bc0b106f0ae8ecd336c7689917e46bc2685603c8
Author: Aravinda VK <avishwan>
Date:   Fri Jul 15 18:49:32 2016 +0530

    cli/xml: Fix wrong XML format in volume get command
    
    Without this Patch,
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volGetopts>
        <count>258</count>
        <Option>cluster.lookup-unhashed</Option>
        <Value>on</Value>
        <Option>cluster.lookup-optimize</Option>
        <Value>off</Value>
        <Option>cluster.min-free-disk</Option>
        <Value>10%</Value>
        <Option>cluster.min-free-inodes</Option>
        <Value>5%</Value>...
    
    With this patch,
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volGetopts>
        <count>258</count>
        <Opt>
            <Option>cluster.lookup-unhashed</Option>
            <Value>on</Value>
        </Opt>
        <Opt>
            <Option>cluster.lookup-optimize</Option>
            <Value>off</Value>
        </Opt>
        <Opt>
            <Option>cluster.min-free-disk</Option>
            <Value>10%</Value>
        </Opt>
        <Opt>
            <Option>cluster.min-free-inodes</Option>
            <Value>5%</Value>
        </Opt>...
    
    BUG: 1302277
    Change-Id: I6c5a040f659f2244ddcd47c57882b4f300cbe52f
    Signed-off-by: Aravinda VK <avishwan>
    Reviewed-on: http://review.gluster.org/14931
    Smoke: Gluster Build System <jenkins.org>
    NetBSD-regression: NetBSD Build System <jenkins.org>
    CentOS-regression: Gluster Build System <jenkins.org>
    Reviewed-by: Jeff Darcy <jdarcy>

Comment 1 Vijay Bellur 2016-07-19 06:17:31 UTC
REVIEW: http://review.gluster.org/14949 (cli/xml: Fix wrong XML format in volume get command) posted (#1) for review on release-3.7 by Aravinda VK (avishwan)

Comment 2 Vijay Bellur 2016-07-28 13:46:43 UTC
REVIEW: http://review.gluster.org/14949 (cli/xml: Fix wrong XML format in volume get command) posted (#2) for review on release-3.7 by Aravinda VK (avishwan)

Comment 3 Vijay Bellur 2016-07-29 19:36:58 UTC
COMMIT: http://review.gluster.org/14949 committed in release-3.7 by Vijay Bellur (vbellur) 
------
commit aa2c33c8104e4870b66f7c5ed52ca7f3daff30a2
Author: Aravinda VK <avishwan>
Date:   Fri Jul 15 18:49:32 2016 +0530

    cli/xml: Fix wrong XML format in volume get command
    
    Without this Patch,
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volGetopts>
        <count>258</count>
        <Option>cluster.lookup-unhashed</Option>
        <Value>on</Value>
        <Option>cluster.lookup-optimize</Option>
        <Value>off</Value>
        <Option>cluster.min-free-disk</Option>
        <Value>10%</Value>
        <Option>cluster.min-free-inodes</Option>
        <Value>5%</Value>...
    
    With this patch,
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volGetopts>
        <count>258</count>
        <Opt>
            <Option>cluster.lookup-unhashed</Option>
            <Value>on</Value>
        </Opt>
        <Opt>
            <Option>cluster.lookup-optimize</Option>
            <Value>off</Value>
        </Opt>
        <Opt>
            <Option>cluster.min-free-disk</Option>
            <Value>10%</Value>
        </Opt>
        <Opt>
            <Option>cluster.min-free-inodes</Option>
            <Value>5%</Value>
        </Opt>...
    
    BUG: 1357766
    Change-Id: I6c5a040f659f2244ddcd47c57882b4f300cbe52f
    Signed-off-by: Aravinda VK <avishwan>
    Reviewed-on: http://review.gluster.org/14931
    (cherry picked from commit bc0b106f0ae8ecd336c7689917e46bc2685603c8)
    Reviewed-on: http://review.gluster.org/14949
    CentOS-regression: Gluster Build System <jenkins.org>
    Smoke: Gluster Build System <jenkins.org>
    NetBSD-regression: NetBSD Build System <jenkins.org>
    Reviewed-by: Vijay Bellur <vbellur>

Comment 4 Kaushal 2016-08-02 07:24:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.14, please open a new bug report.

glusterfs-3.7.14 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-August/050319.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.