Bug 1302331 - Tag control dropdown is broken
Tag control dropdown is broken
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Martin Hradil
Milan Falešník
ui:automate
: ZStream
Depends On:
Blocks: 1321595
  Show dependency treegraph
 
Reported: 2016-01-27 09:03 EST by Milan Falešník
Modified: 2016-06-29 11:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1321595 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:33:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Falešník 2016-01-27 09:03:25 EST
Description of problem:
A followup to BZ#1282949 , the tag control dropdown is now rendered but breaks when clicked.


Version-Release number of selected component (if applicable):
5.5.2.2

How reproducible:
always

Steps to Reproduce:
1. Create a dialog containing a Tag Control type of element
2. Create some service that uses that dialog.
3. Open the Order dialog
4. Select some tag from the tag control

Actual results:
An original <select> appears next to the styled select, no action seems to happen subsequently (I have refresh set up on that element with quite long dynamic dropdown methods for other dynamic dropdowns that are present in the dialog and only a very short spinner appears although it is set to do the Auto Refresh on change)

Expected results:
That it will behave the same like another styled selects. And in my case a longer spinner since the methods for retrieving the other two dynamic dropdowns take some time

Additional info:
I have spoken to mhradil about this issue.
Comment 4 Martin Hradil 2016-01-28 12:36:33 EST
the main problem is actually already fixed in master:


commit 9a828a49722abee887fa786a872ed23c3080a24f
Author: Lubneuski Aliaksandr <lubagabit@gmail.com>
Date:   Sat Jan 16 11:42:52 2016 +0300

    TagControl field fix
Comment 5 Martin Hradil 2016-02-02 12:10:02 EST
https://github.com/ManageIQ/manageiq/pull/6476
Comment 6 CFME Bot 2016-02-11 19:21:18 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/8f45d8e8258195f6226c77db4ea52ba369f72753

commit 8f45d8e8258195f6226c77db4ea52ba369f72753
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Wed Jan 27 15:25:39 2016 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Tue Feb 2 17:12:24 2016 +0000

    DialogRunner - fix miq_observe functionality on selectpickers
    
    depends on 9a828a49722abee887fa786a872ed23c3080a24f, which is the important part of the fix
    
    this fixes initializeDialogSelectPicker to not assume trigger_auto_refresh by default
    and calls that instead of miqInitSelectPicker + miqSelectPickerEvent (both are called from initializeDialogSelectPicker)
    
    also selectedValue is made optional (because it is already handled by select_tag)
    
    also, the data-miq_observe attribue is removed from drop_downs, since that functionality is handled by miqSelectPickerEvent for selectpickers
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1302331

 app/assets/javascripts/dialog_field_refresh.js   | 10 ++++++----
 app/helpers/application_helper/dialogs.rb        |  2 +-
 app/views/shared/dialogs/_dialog_field.html.haml |  3 +--
 3 files changed, 8 insertions(+), 7 deletions(-)
Comment 9 CFME Bot 2016-02-15 10:41:25 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 12 Milan Falešník 2016-03-24 09:31:04 EDT
Verified in 5.5.3.2, the tag control is rendered correctly, does not break and passes correct values.
Comment 13 CFME Bot 2016-05-11 12:22:08 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=aeda3e68633daacfcc8f058393c60ecce0d0ccaf

commit aeda3e68633daacfcc8f058393c60ecce0d0ccaf
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Wed Jan 27 10:25:39 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue May 10 16:09:39 2016 -0400

    DialogRunner - fix miq_observe functionality on selectpickers
    
    depends on 9a828a49722abee887fa786a872ed23c3080a24f, which is the important part of the fix
    
    this fixes initializeDialogSelectPicker to not assume trigger_auto_refresh by default
    and calls that instead of miqInitSelectPicker + miqSelectPickerEvent (both are called from initializeDialogSelectPicker)
    
    also selectedValue is made optional (because it is already handled by select_tag)
    
    also, the data-miq_observe attribue is removed from drop_downs, since that functionality is handled by miqSelectPickerEvent for selectpickers
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1302331
    (cherry picked from commit 8f45d8e)

 app/assets/javascripts/dialog_field_refresh.js   | 10 ++++++----
 app/helpers/application_helper/dialogs.rb        |  2 +-
 app/views/shared/dialogs/_dialog_field.html.haml |  3 +--
 3 files changed, 8 insertions(+), 7 deletions(-)
Comment 14 CFME Bot 2016-05-11 12:22:13 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=59b1c2bd7190c98d91bdbf796f76dc5640c245cc

commit 59b1c2bd7190c98d91bdbf796f76dc5640c245cc
Merge: d390c6e 7d72527
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed May 11 11:53:51 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed May 11 11:53:51 2016 -0400

    Merge branch '55z_pr_6476_mhradil' into '5.5.z'
    
    DialogRunner - fix miq_observe functionality on selectpickers
    
    @dclarizi please review, cherry-picked from https://github.com/ManageIQ/manageiq/pull/6476 with minor merge conflicts
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1302331
    
    See merge request !932

 app/assets/javascripts/dialog_field_refresh.js     | 12 +++++---
 .../application_controller/dialog_runner.rb        |  5 ---
 app/helpers/application_helper/dialogs.rb          |  2 +-
 app/views/report/_menu_form1.html.haml             | 36 ++++++++++++----------
 app/views/shared/dialogs/_dialog_field.html.haml   |  3 +-
 spec/helpers/application_helper/dialogs_spec.rb    | 30 +++++++++---------
 spec/javascripts/dialog_field_refresh_spec.js      |  8 ++++-
 7 files changed, 50 insertions(+), 46 deletions(-)
Comment 16 errata-xmlrpc 2016-06-29 11:33:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.