Bug 1282949 - Service dialog Tag Control elements do not render when service is ordered.
Service dialog Tag Control elements do not render when service is ordered.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: eclarizi
Jeff Teehan
ui:tag
:
: 1284904 1298582 (view as bug list)
Depends On:
Blocks: 1227937 1289641
  Show dependency treegraph
 
Reported: 2015-11-17 16:25 EST by Jeff Teehan
Modified: 2016-06-29 11:08 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289641 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:08:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot after applying commit from comment #4 (40.59 KB, image/png)
2016-01-17 07:45 EST, Henry Geay de Montenon
no flags Details
Graphical bug after RHBA-2016:0159 (76.59 KB, image/png)
2016-02-23 03:36 EST, Henry Geay de Montenon
no flags Details

  None (edit)
Description Jeff Teehan 2015-11-17 16:25:45 EST
Description of problem:
In Verifying one bz, I found an issue when I created a Service dialog box containing a Tag Control element with a category of Department, then created a generic Service Catalog which used that Dialog.

When the service was Ordered, the label for the element appeared but not the Element itself.  I tried with Single Item, multiselect and other options, but it not displayed.


Version-Release number of selected component (if applicable):


How reproducible:
I reproduced on 5.5.0.10, and 5.5.0.9
I tried on 5.4.3 with the same steps and it worked fine, so this is definitely a 5.5 issue.

Steps to Reproduce:
1.  Create the Service dialog with a Tag Control element set to Department
2.  Create a Service Catalog item which uses that Dialog
3.  Order the Service.

Actual results:
Element does not render.

Expected results:
Element

Additional info:

If you act reasonably soon, you can see it with 5.5.0.9 which I'll leave running for a while at https://10.16.6.101
Comment 2 Greg McCullough 2015-11-24 08:48:00 EST
*** Bug 1284904 has been marked as a duplicate of this bug. ***
Comment 4 CFME Bot 2015-12-11 18:08:11 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/8c94c65465542afb9fc5ede7f83531ae1380fb74

commit 8c94c65465542afb9fc5ede7f83531ae1380fb74
Author:     Erik Clarizio <eclarizi@redhat.com>
AuthorDate: Fri Dec 11 09:10:12 2015 -0800
Commit:     Erik Clarizio <eclarizi@redhat.com>
CommitDate: Fri Dec 11 10:02:15 2015 -0800

    Enable selectpicker javascript for tag control dialog fields
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1282949

 app/views/shared/dialogs/_dialog_field.html.haml | 4 ++++
 1 file changed, 4 insertions(+)
Comment 5 Greg McCullough 2016-01-14 10:13:31 EST
*** Bug 1298582 has been marked as a duplicate of this bug. ***
Comment 7 Henry Geay de Montenon 2016-01-17 07:45 EST
Created attachment 1115593 [details]
screenshot after applying commit from comment #4
Comment 8 Henry Geay de Montenon 2016-01-17 07:46:08 EST
Just tested the commit from comment #4 in my test environment, and while it allows the dropdown to show initially, once an entry is selected it causes a display issue (as shown in attached screenshot)
Comment 9 eclarizi 2016-01-19 11:58:48 EST
I just pulled the latest 5.5.z and didn't have any issues with the tag control, even after selecting things. Here is the related BZ where the changes got merged to the 5.5.z stream: https://bugzilla.redhat.com/show_bug.cgi?id=1289641
Comment 10 Henry Geay de Montenon 2016-02-23 03:34:09 EST
Applied RHBA-2016:0159 and still facing the graphical bug i had with the hotfix ... screenshot attached.
Comment 11 Henry Geay de Montenon 2016-02-23 03:36 EST
Created attachment 1129673 [details]
Graphical bug after RHBA-2016:0159

- after selecting from a tag control element, a new dropdown appears (cannot be used to select anything)
- after selecting an element from a dynamic dropdown with a refresh button, a new button appear. A new one also appears every time the user would change his mind about the item to select in the list.
Comment 12 Jeff Teehan 2016-03-28 14:39:47 EDT
Verified working as before.  Moving to verified.
https://10.16.6.154/catalog/explorer running 5.6 Beta 1
Comment 15 errata-xmlrpc 2016-06-29 11:08:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.