This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1302338 - [RFE] Database backup doesn't expire files from within the backup
[RFE] Database backup doesn't expire files from within the backup
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: John Hardy
Alex Newman
: FutureFeature
: 1302340 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 09:20 EST by Martin Welk
Modified: 2017-08-28 11:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 11:03:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Welk 2016-01-27 09:20:16 EST
Description of problem:
I've seen some customers doing block based backups of their virtual machines. They can extract single files from those backups for restore.
So, for CloudForms they have the idea to create an NFS share on the CFME appliance itself, and run the backup into that NFS share. That works well, but the share fills up and they have to clean it manually or through an external job. It would be nice if the backup schedule could expire older files.

Version-Release number of selected component (if applicable):
n/a

How reproducible:
100%

Steps to Reproduce:
1. Create an NFS share
2. Create backups on a daily basis
3. Watch the used space growing

Actual results:
Some day, the disk is full

Expected results:
CloudForms can be told to keep some (for example, three) backups of the database, and expires the older ones automatically

Additional info:
I think this is a good idea as we ship CFME as a VM appliance, and many customers use block based backups and prefer that to other solutions. Furthermore, using an NFS share "on localhost" reduces external dependencies.
Comment 2 Martin Welk 2016-01-27 09:39:12 EST
*** Bug 1302340 has been marked as a duplicate of this bug. ***
Comment 3 Shveta 2016-02-01 16:32:35 EST
Assigning to add test case
Comment 5 Chris Pelland 2017-08-28 11:03:31 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.