Bug 1302340 - Database backup doesn't expire files from within the backup
Database backup doesn't expire files from within the backup
Status: CLOSED DUPLICATE of bug 1302338
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
x86_64 Linux
unspecified Severity low
: GA
: 5.6.0
Assigned To: Gregg Tanzillo
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 09:22 EST by Martin Welk
Modified: 2016-01-27 09:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 09:39:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Welk 2016-01-27 09:22:29 EST
Description of problem:
I've seen some customers doing block based backups of their virtual machines. They can extract single files from those backups for restore.
So, for CloudForms they have the idea to create an NFS share on the CFME appliance itself, and run the backup into that NFS share. That works well, but the share fills up and they have to clean it manually or through an external job. It would be nice if the backup schedule could expire older files.

Version-Release number of selected component (if applicable):
n/a

How reproducible:
100%

Steps to Reproduce:
1. Create an NFS share
2. Create backups on a daily basis
3. Watch the used space growing

Actual results:
Some day, the disk is full

Expected results:
CloudForms can be told to keep some (for example, three) backups of the database, and expires the older ones automatically

Additional info:
I think this is a good idea as we ship CFME as a VM appliance, and many customers use block based backups and prefer that to other solutions. Furthermore, using an NFS share "on localhost" reduces external dependencies.
Comment 2 Martin Welk 2016-01-27 09:39:12 EST
I am sorry. I got an error when I submitted this the first time. This one's a duplicate.

*** This bug has been marked as a duplicate of bug 1302338 ***

Note You need to log in before you can comment on or make changes to this bug.