Bug 1302352 - AttributeError: 'NoneType' object has no attribute 'mountpoints'
AttributeError: 'NoneType' object has no attribute 'mountpoints'
Status: CLOSED DUPLICATE of bug 1294700
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 09:58 EST by Alexander Todorov
Modified: 2016-01-27 14:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:34:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2016-01-27 09:58:09 EST
Description of problem:

anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 550, in spaceRequired
    for (key, val) in self.storage.mountpoints.items():
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/lib/space.py", line 76, in check
    needed = self.payload.spaceRequired
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 79, in prompt
    if self._checker and not self._checker.check():
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 346, in _mainloop
    prompt = last_screen.prompt(self._screens[-1][1])
AttributeError: 'NoneType' object has no attribute 'mountpoints'

Local variables in innermost frame:
download_size: 0 B
root_mpoint: /mnt/sysimage
size: 2.79 GiB
valid_points: {'/dev/shm': Size('15.68 GiB'), '/run/install/repo': Size('1 MiB'), '/dev': Size('15.66 GiB'), '/sys/fs/cgroup': Size('15.68 GiB'), '/tmp': Size('15.66 GiB'), '/': Size('940.67 MiB'), '/run': Size('15.66 GiB')}
self: <pyanaconda.packaging.dnfpayload.DNFPayload object at 0x7fd3d169dc50>


This happened with a regular kickstart install today. I've not seen it before with the same ks. Here's my kicstart file:



nfs --server example.com --dir /pub/fedora/linux/releases/23/Server/x86_64/os/

# System bootloader configuration
bootloader --location=mbr
text
# no specific network configuration

repo --name=fedora-updates --mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f23&arch=x86_64
repo --name=beaker-Server-debuginfo --cost=100 --baseurl=http://example.com/pub/fedora/linux/releases/23/Server/x86_64/debug
repo --name=beaker-Fedora-Everything --cost=100 --baseurl=http://example.com/pub/fedora/linux/releases/23/Everything/x86_64/os
repo --name=beaker-Fedora --cost=100 --baseurl=http://example.com/pub/fedora/linux/releases/23/Server/x86_64/os/

firewall --disabled
# Run the Setup Agent on first boot
firstboot --disable
# System keyboard
keyboard us
# System language
lang en_US.UTF-8

reboot
#Root password
rootpw example
# SELinux configuration
selinux --enforcing


timezone Europe/Sofia
install

zerombr
clearpart --all --initlabel

autopart

%packages --ignoremissing
@desktop-platform-devel
@development
@development-libs
@development-tools
@server-platform-devel
emacs
expect
gcc
libxml2-python
make
nfs-utils
ntp
procmail
psmisc
pyOpenSSL
redhat-lsb
sendmail
vim-enhanced
wget
chrony
%end
Comment 1 David Shea 2016-01-27 14:34:06 EST

*** This bug has been marked as a duplicate of bug 1294700 ***

Note You need to log in before you can comment on or make changes to this bug.