Bug 1294700 - AttributeError: 'NoneType' object has no attribute 'mountpoints'
AttributeError: 'NoneType' object has no attribute 'mountpoints'
Status: CLOSED DUPLICATE of bug 1271657
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9d34b5e2fe2655fd089ce096780...
:
: 1302352 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 14:31 EST by Darrell Duane
Modified: 2016-02-25 04:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 04:12:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (349.37 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: anaconda.log (21.04 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: dnf.log (4.48 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: dnf.rpm.log (490 bytes, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: environ (459 bytes, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: lsblk_output (1.87 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: nmcli_dev_list (1.53 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: os_info (451 bytes, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: storage.log (75.36 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: syslog (119.03 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: ifcfg.log (4.50 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: packaging.log (3.21 KB, text/plain)
2015-12-29 14:31 EST, Darrell Duane
no flags Details
File: program.log (49.28 KB, application/octet-stream)
2015-12-29 14:31 EST, Darrell Duane
no flags Details

  None (edit)
Description Darrell Duane 2015-12-29 14:31:06 EST
Description of problem:
Installing on to a new System76 laptop (Gazelle) with a 250 GB sd drive.

Version-Release number of selected component:
anaconda-23.19.10-1

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 550, in spaceRequired
    for (key, val) in self.storage.mountpoints.items():
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 87, in __init__
    self._required_label.set_markup(markup % escape_markup(str(self.payload.spaceRequired)))
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 961, in on_back_clicked
    dialog = ResizeDialog(self.data, self.storage, self.payload)
AttributeError: 'NoneType' object has no attribute 'mountpoints'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-WS-23-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Darrell Duane 2015-12-29 14:31:11 EST
Created attachment 1110310 [details]
File: anaconda-tb
Comment 2 Darrell Duane 2015-12-29 14:31:13 EST
Created attachment 1110311 [details]
File: anaconda.log
Comment 3 Darrell Duane 2015-12-29 14:31:14 EST
Created attachment 1110312 [details]
File: dnf.log
Comment 4 Darrell Duane 2015-12-29 14:31:15 EST
Created attachment 1110313 [details]
File: dnf.rpm.log
Comment 5 Darrell Duane 2015-12-29 14:31:16 EST
Created attachment 1110314 [details]
File: environ
Comment 6 Darrell Duane 2015-12-29 14:31:17 EST
Created attachment 1110315 [details]
File: lsblk_output
Comment 7 Darrell Duane 2015-12-29 14:31:18 EST
Created attachment 1110316 [details]
File: nmcli_dev_list
Comment 8 Darrell Duane 2015-12-29 14:31:19 EST
Created attachment 1110317 [details]
File: os_info
Comment 9 Darrell Duane 2015-12-29 14:31:20 EST
Created attachment 1110318 [details]
File: storage.log
Comment 10 Darrell Duane 2015-12-29 14:31:21 EST
Created attachment 1110319 [details]
File: syslog
Comment 11 Darrell Duane 2015-12-29 14:31:22 EST
Created attachment 1110320 [details]
File: ifcfg.log
Comment 12 Darrell Duane 2015-12-29 14:31:23 EST
Created attachment 1110321 [details]
File: packaging.log
Comment 13 Darrell Duane 2015-12-29 14:31:24 EST
Created attachment 1110322 [details]
File: program.log
Comment 14 David Shea 2016-01-27 14:34:06 EST
*** Bug 1302352 has been marked as a duplicate of this bug. ***
Comment 15 Aleš Mareček 2016-02-18 04:43:17 EST
Hello guys,
any progress here? It seems like it's blocker in provisioning.
Comment 16 Alexander Todorov 2016-02-25 04:12:34 EST
Ales,
please see the duplicate bug.

*** This bug has been marked as a duplicate of bug 1271657 ***

Note You need to log in before you can comment on or make changes to this bug.