Bug 1302417 - Starting container sometimes fails on docker 1.9.1-14
Starting container sometimes fails on docker 1.9.1-14
Status: CLOSED DUPLICATE of bug 1302418
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Walsh
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 14:48 EST by Andy Goldstein
Modified: 2016-01-27 15:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 15:20:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Goldstein 2016-01-27 14:48:01 EST
Description of problem: When starting several containers in rapid succession, some of them fail to start.


Version-Release number of selected component (if applicable): docker-1.9.1-14.el7


How reproducible: occasionally


Steps to Reproduce:
1. docker pull busybox
2. for i in `seq 1 100`; do docker run -d busybox sleep 1d; done

Actual results: most containers start ok, but some fail to start with an error like this:

Error response from daemon: Cannot start container 51cf9a82241f081ed9102875dd937906fb68b413618f883a0ab62f9421d51870: [8] System error: write /sys/fs/cgroup/devices/system.slice/docker-51cf9a82241f081ed9102875dd937906fb68b413618f883a0ab62f9421d51870.scope/cgroup.procs: no such device



Expected results: all containers start ok


Additional info:

docker-1.8.2-10 doesn't appear to have this issue. docker-1.9.1-4 on Fedora 23 doesn't appear to have this issue either.

I've done a bit of testing of upstream docker HEAD (commit fff1511c56e35cf5230d05af2282d31d23a31dc0) and so far haven't been able to reproduce.
Comment 2 Andy Goldstein 2016-01-27 15:20:00 EST
Bugzilla was giving me errors when I tried to create this bug, and apparently it created 2 copies. I'm closing this one in favor of https://bugzilla.redhat.com/show_bug.cgi?id=1302418.

*** This bug has been marked as a duplicate of bug 1302418 ***

Note You need to log in before you can comment on or make changes to this bug.