Bug 1302418 - Starting container sometimes fails on Docker 1.9.1-14
Starting container sometimes fails on Docker 1.9.1-14
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
: 1302417 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 14:48 EST by Andy Goldstein
Modified: 2016-03-31 19:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:23:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Goldstein 2016-01-27 14:48:51 EST
Description of problem: When starting several containers in rapid succession, some of them fail to start.


Version-Release number of selected component (if applicable): docker-1.9.1-14.el7


How reproducible: occasionally


Steps to Reproduce:
1. docker pull busybox
2. for i in `seq 1 100`; do docker run -d busybox sleep 1d; done

Actual results: most containers start ok, but some fail to start with an error like this:

Error response from daemon: Cannot start container 51cf9a82241f081ed9102875dd937906fb68b413618f883a0ab62f9421d51870: [8] System error: write /sys/fs/cgroup/devices/system.slice/docker-51cf9a82241f081ed9102875dd937906fb68b413618f883a0ab62f9421d51870.scope/cgroup.procs: no such device



Expected results: all containers start ok


Additional info:

docker-1.8.2-10 doesn't appear to have this issue. docker-1.9.1-4 on Fedora 23 doesn't appear to have this issue either.

I've done a bit of testing of upstream docker HEAD (commit fff1511c56e35cf5230d05af2282d31d23a31dc0) and so far haven't been able to reproduce.
Comment 1 Timothy St. Clair 2016-01-27 14:55:47 EST
similar type of error: 
https://github.com/kubernetes/kubernetes/issues/19801

Cannot start container 0cd17636f7334a0481053ceecc64851a1119e332ce8c0172c7de02a157e68018: [8] System error: open /sys/fs/cgroup/cpu,cpuacct/system.slice/docker-0cd17636f7334a0481053ceecc64851a1119e332ce8c0172c7de02a157e68018.scope/cpu.shares: no such file or directory
Comment 3 Andy Goldstein 2016-01-27 15:20:00 EST
*** Bug 1302417 has been marked as a duplicate of this bug. ***
Comment 6 Timothy St. Clair 2016-01-27 17:51:28 EST
I did reproduce the similar error above on docker-1.9.1-4.git6ec29ef.fc23.x86_64 using the test case linked in the github issue.
Comment 7 Daniel Walsh 2016-01-27 17:54:50 EST
Lokesh, I merged in mrunal fix, could you do another build.
Comment 9 Daniel Walsh 2016-02-22 14:30:03 EST
Fixed in docker-1.9.1-14
Comment 11 Luwen Su 2016-03-17 12:08:48 EDT
The steps are fine for me in docker-1.9.1-23.el7.x86_64, move to verified
Comment 13 errata-xmlrpc 2016-03-31 19:23:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0536.html

Note You need to log in before you can comment on or make changes to this bug.