Bug 1302450 - Delete button enabled after filter is deleted in advanced search expression editor [NEEDINFO]
Delete button enabled after filter is deleted in advanced search expression e...
Status: CLOSED DUPLICATE of bug 1298645
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Nandini Chandra
ui:search
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 18:00 EST by Nandini Chandra
Modified: 2016-03-21 10:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 10:42:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dclarizi: needinfo? (dajohnso)


Attachments (Terms of Use)
Delete button enabled in Advanced Search expression editor (60.46 KB, image/png)
2016-01-27 18:00 EST, Nandini Chandra
no flags Details

  None (edit)
Description Nandini Chandra 2016-01-27 18:00:34 EST
Created attachment 1118892 [details]
Delete button enabled in Advanced Search expression editor

Description of problem:
-----------------------
I ran into this issue while verifying 
https://bugzilla.redhat.com/show_bug.cgi?id=1295526

In the advanced search expression editor,the Delete button is still enabled after a filter is deleted.

Version-Release number of selected component (if applicable):
---------------------
5.5.2.2


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1. Go to the Providers, advanced search, specify some random conditions as a filter and then save it
2. Load the filter.
3. Click Delete.


Actual results:
--------------
Notice that after deleting the filter,the Delete button is still enabled 
in the advanced search expression editor.

Clicking on this Delete button results in a UI error.


Expected results:
-----------------
Delete button should be disabled after filter is deleted in advanced search expression editor.


Additional info:
---------------
Comment 3 Shveta 2016-02-02 19:14:34 EST
Assigning to add test case
Comment 4 Harpreet Kataria 2016-03-21 10:42:02 EDT

*** This bug has been marked as a duplicate of bug 1298645 ***

Note You need to log in before you can comment on or make changes to this bug.