Bug 1302453 - on update, facter version downgrades
on update, facter version downgrades
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: facter (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: async
: 7.0 (Kilo)
Assigned To: Mike Burns
: OtherQA, ZStream
Depends On:
Blocks: 1302455
  Show dependency treegraph
 
Reported: 2016-01-27 18:18 EST by Mike Burns
Modified: 2016-02-01 10:12 EST (History)
5 users (show)

See Also:
Fixed In Version: facter-2.4.3-3.el7
Doc Type: Bug Fix
Doc Text:
Previously, an older version of facter with a later Epoch was available in the Red Hat Common repository. If the Red Hat Common repository was enabled, this older version would be used instead of 2.4.3, which is the version required for Red Hat Enterprise Linux Platform 7. With this update, the Epoch of facter 2.4.3 has been increased to '1' so that version 2.4.3 of facter is preserved.
Story Points: ---
Clone Of:
: 1302455 (view as bug list)
Environment:
Last Closed: 2016-02-01 10:12:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2016-01-27 18:18:55 EST
Description of problem:
When updating a director deployed overcloud, facter appears to be downgraded from 2.4.3-1 to 1.7.6-2.1.  This is because there is a version of facter in the rhel-7-server-rh-common-rpms with an epoch value that makes it newer than the version shipped in RHEL-OSP.

Version-Release number of selected component (if applicable):
facter-2.3.4-1.el7ost

How reproducible:
always

Steps to Reproduce:
1.deploy overcloud
2.update overcloud
3.check facter version on updated nodes

Actual results:
facter-1.7.6-2.1.el7sat is installed

Expected results:
facter-2.4.3-1.el7 is installed

Additional info:
Comment 9 errata-xmlrpc 2016-02-01 10:12:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0094.html

Note You need to log in before you can comment on or make changes to this bug.