Bug 1302455 - on update, facter version downgrades
on update, facter version downgrades
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: facter (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Jon Schlueter
: TestOnly, Triaged, ZStream
Depends On: 1302453
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 18:20 EST by Mike Burns
Modified: 2016-12-01 13:27 EST (History)
4 users (show)

See Also:
Fixed In Version: facter-2.4.3-3.el7
Doc Type: Bug Fix
Doc Text:
Cause: RHEL common is shipping older version of factor with a higher epoch than the version we were shipping with OSP Consequence: users would see a downgrade of factor if rhel common repo was enabled which would break director Fix: bump epoch of our version of the package so that it would continue to install the correct version for director. Result: user would not see downgrade of factor and break things.
Story Points: ---
Clone Of: 1302453
Environment:
Last Closed: 2016-12-01 13:27:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2016-01-27 18:20:43 EST
+++ This bug was initially created as a clone of Bug #1302453 +++

Description of problem:
When updating a director deployed overcloud, facter appears to be downgraded from 2.4.3-1 to 1.7.6-2.1.  This is because there is a version of facter in the rhel-7-server-rh-common-rpms with an epoch value that makes it newer than the version shipped in RHEL-OSP.

Version-Release number of selected component (if applicable):
facter-2.3.4-1.el7ost

How reproducible:
always

Steps to Reproduce:
1.deploy overcloud
2.update overcloud
3.check facter version on updated nodes

Actual results:
facter-1.7.6-2.1.el7sat is installed

Expected results:
facter-2.4.3-1.el7 is installed

Additional info:
Comment 7 Jon Schlueter 2016-12-01 12:52:55 EST
verified that current version of facter from OSP 8 is installed if OSP 8 channels are enabled: 


====================================================================================================================================
 Package                        Arch               Version                                Repository                           Size
====================================================================================================================================
Installing:
 facter                         x86_64             1:2.4.3-3.el7                          rhelosp-8.0-puddle                  101 k
Comment 8 Mike Burns 2016-12-01 13:27:11 EST
verified

Note You need to log in before you can comment on or make changes to this bug.