Bug 1302480 - nodejs-js-beautify-v1.6.3 is available
nodejs-js-beautify-v1.6.3 is available
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nodejs-js-beautify (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 19:20 EST by Upstream Release Monitoring
Modified: 2016-08-15 15:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 06:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to bring specfile up to version 1.6.2 and fix some problems (2.85 KB, patch)
2016-02-08 19:13 EST, Jared Smith
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (16.72 KB, patch)
2016-06-03 08:17 EDT, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2016-01-27 19:20:59 EST
Latest upstream release: v1.6.0-0
Current version/release in rawhide: 1.5.10-4.fc24
URL: https://github.com/beautify-web/js-beautify

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2016-01-27 19:21:05 EST
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-GQmzUY/nodejs-js-beautify.spec
return code:  22
stdout:
Getting https://github.com/beautify-web/js-beautify/archive/vv1.6.0/nodejs-js-beautify-v1.6.0.tar.gz to ./nodejs-js-beautify-v1.6.0.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   159    0   159    0     0    415      0 --:--:-- --:--:-- --:--:--   416

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 2 Upstream Release Monitoring 2016-01-31 07:28:25 EST
Latest upstream release: v1.6.1
Current version/release in rawhide: 1.5.10-4.fc24
URL: https://github.com/beautify-web/js-beautify

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 3 Upstream Release Monitoring 2016-01-31 07:28:31 EST
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-Xom6bd/nodejs-js-beautify.spec
return code:  22
stdout:
Getting https://github.com/beautify-web/js-beautify/archive/vv1.6.1/nodejs-js-beautify-v1.6.1.tar.gz to ./nodejs-js-beautify-v1.6.1.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   159    0   159    0     0    422      0 --:--:-- --:--:-- --:--:--   422

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 4 Upstream Release Monitoring 2016-01-31 19:14:48 EST
Latest upstream release: v1.6.2
Current version/release in rawhide: 1.5.10-4.fc24
URL: https://github.com/beautify-web/js-beautify

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 5 Upstream Release Monitoring 2016-01-31 19:14:53 EST
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-WG9r5m/nodejs-js-beautify.spec
return code:  22
stdout:
Getting https://github.com/beautify-web/js-beautify/archive/vv1.6.2/nodejs-js-beautify-v1.6.2.tar.gz to ./nodejs-js-beautify-v1.6.2.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   159    0   159    0     0    482      0 --:--:-- --:--:-- --:--:--   483

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 6 Jared Smith 2016-02-08 19:13 EST
Created attachment 1122300 [details]
Patch to bring specfile up to version 1.6.2 and fix some problems
Comment 7 Jared Smith 2016-02-08 19:14:17 EST
I'm attaching a patch for the specfile that will build version 1.6.2, as well as fix some other problems in your packaging -- specifically that your module doesn't currently work when called as part of a NodeJS program, because package.json points to js/index.js, but you are not packaging index.js.

Please review this patch, and let me know if you have any questions.  If I don't hear back from you in a few days, I'll use my powers as a provenpackager to go ahead and update this package, as it's blocking some other NodeJS packages I'm working on.
Comment 8 Eduardo Mayorga 2016-02-13 01:25:19 EST
The build fails due to missing dependencies:

DEBUG util.py:474:  Executing command: ['/usr/bin/dnf', 'builddep', '--installroot', '/var/lib/mock/fedora-rawhide-x86_64/root/', '--releasever', '24', '/var/lib/mock/fedora-rawhide-x86_64/root//builddir/build/SRPMS/nodejs-js-beautify-1.6.2-1.fc24.src.rpm', '--setopt=tsflags=nocontexts'] with env {'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'LANG': 'es_NI.UTF-8', 'HOME': '/builddir', 'CCACHE_DIR': '/tmp/ccache', 'PROMPT_COMMAND': 'printf "\x1b]0;<mock-chroot>\x07<mock-chroot>"', 'SHELL': '/bin/bash', 'CCACHE_UMASK': '002', 'LC_MESSAGES': 'C', 'HOSTNAME': 'mock', 'TERM': 'vt100'} and shell False
DEBUG util.py:399:  Last metadata expiration check performed 0:00:06 ago on Thu Feb 11 09:31:25 2016.
DEBUG util.py:399:  No matching package to install: 'npm(benchmark)'
DEBUG util.py:399:  No matching package to install: 'npm(jshint)'
DEBUG util.py:399:  Not all dependencies satisfied
DEBUG util.py:399:  Error: Some packages could not be found.
DEBUG util.py:521:  Child return code was: 1

I see benchmark is in review (bug #1274736), but what about jshint? Do you plan to submit it? If so, I could push your changes and wait to build until these packages are imported.
Comment 9 Jared Smith 2016-02-13 12:01:58 EST
Yes, I'll go ahead and push jshint in, once I finish packaging it's dependencies.
Comment 10 Fedora Admin XMLRPC Client 2016-04-25 23:48:22 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Upstream Release Monitoring 2016-06-03 08:17:23 EDT
Latest upstream release: v1.6.3
Current version/release in rawhide: 1.5.10-5.fc24
URL: https://github.com/beautify-web/js-beautify

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/7997/
Comment 12 Upstream Release Monitoring 2016-06-03 08:17:33 EDT
Patching or scratch build for nodejs-js-beautify-1.5.10 failed.
Comment 13 Upstream Release Monitoring 2016-06-03 08:17:35 EDT
Created attachment 1164461 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 14 Upstream Release Monitoring 2016-06-03 08:17:37 EDT
Patches were not touched. All were applied properly
Comment 15 Jeroen van Meeuwen 2016-08-04 06:11:33 EDT
See Bug #1363763 for the revival of the orphaned package.

Note You need to log in before you can comment on or make changes to this bug.