Bug 1302509 - [Docs] [RFE] Gateway setting for non-management networks lacks explanation in Administration Guide.
[Docs] [RFE] Gateway setting for non-management networks lacks explanation in...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.7
All Linux
unspecified Severity medium
: ovirt-3.6.8
: ---
Assigned To: Byron Gravenorst
Megan Lewis
: FutureFeature
: 1302508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 21:31 EST by Germano Veit Michel
Modified: 2016-07-31 23:20 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-31 23:20:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germano Veit Michel 2016-01-27 21:31:36 EST
Description of problem:

In RHEV-M GUI, if we fill the Gateway setting the management network this address is used for the default route.

However, if we fill it for non-management networks, we are actually setting up source based routing by using special routing tables and ip rules to instruct the kernel to look at specific tables in the FIB for packets which have specific source-IP/interfaces. See: http://www.ovirt.org/Features/Multiple_Gateways

Our documentation in https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Administration_Guide/sect-Hosts_and_Networking.html (section 7.6.2. Editing Host Network Interfaces and Assigning Logical Networks to Hosts) does not mention this important detail. 

So people fill the gateway option for non management networks and expect that gateway to be the default route for the Host. But it is not since it's only valid for forwarding (not in use) or reply packets arriving from that Network (some conntrack magic here I suppose).

So I suggest we put a note in there to link some other part of the documentation or to explain these differences.

I haven't confirmed this in 3.6 but I suppose it's the same.

Cheers,
Germano
Comment 2 Andrew Dahms 2016-02-02 07:11:45 EST
*** Bug 1302508 has been marked as a duplicate of this bug. ***
Comment 3 Lucy Bopf 2016-05-03 02:24:22 EDT
Assigning to Byron for review.
Comment 6 Byron Gravenorst 2016-06-12 20:59:28 EDT
Hi Assaf,

I'm currently adding some documentation for this feature, however I'm hoping someone could confirm that this is still valid in RHEV 4.0.

Hoping you could help with this, or perhaps forward this to someone who can?

Kind regards,
Comment 7 Dan Kenigsberg 2016-07-19 08:11:26 EDT
Yes, this is valid for 4.0, and not expected to change in the near future.

Note You need to log in before you can comment on or make changes to this bug.