Bug 1302514 - Can't show "Rule Engine Rule" after rule updates a bug
Can't show "Rule Engine Rule" after rule updates a bug
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 22:12 EST by Hui Wang
Modified: 2016-02-15 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 18:22:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2016-01-27 22:12:19 EST
Description of problem:
After rule updating a bug, the "Rule Engine Rule" can't show in bug comment.

e.g., if the rule updates the pm_ack flag in version 4.4.11046.4, it shows:

Red Hat Bugzilla Rules Engine 2016-01-28 03:02:41 EST
Flags: pm_ack? → pm_ack+
Rule Engine Rule: RHEL 7 pm_ack+ PPC LE

if the rule updates the pm_ack flag in version 4.4.11048.1, it shows:

Red Hat Bugzilla Rules Engine 2016-01-27 21:39:30 UTC
Flags: pm_ack+ → pm_ack?

Version-Release number of selected component (if applicable):
version 4.4.11048.1

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Red Hat Bugzilla Rules Engine 2016-01-27 21:39:30 UTC
Flags: pm_ack+ → pm_ack?


Expected results:
Red Hat Bugzilla Rules Engine 2016-01-28 03:02:41 EST
Flags: pm_ack? → pm_ack+
Rule Engine Rule: RHEL 7 pm_ack+ PPC LE


Additional info:
Comment 1 Matt Tyson 2016-02-02 22:24:03 EST
This was actually caused by a regression introduced by bug 1287318.

When you retest 1287318, please test that this issue is fixed.
Comment 2 Hui Wang 2016-02-03 00:32:35 EST
Verified this issue.
The result is PASS.
version 4.4.11048.2

Additional info:
Red Hat Bugzilla Rules Engine 2016-02-03 00:30:51 UTC
Flags: pm_ack? → pm_ack+
Rule Engine Rule: RHEL 7 pm_ack+ PPC LE
Comment 3 Matt Tyson 2016-02-15 18:22:34 EST
Fixed in bug 1287318

Note You need to log in before you can comment on or make changes to this bug.