Bug 1302539 - [Docs][Admin][RFE] MAC address pool assigned per data center
[Docs][Admin][RFE] MAC address pool assigned per data center
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-3.6.4
: ---
Assigned To: Megan Lewis
Tahlia Richardson
http://www.ovirt.org/develop/api/desi...
: FutureFeature
: 1320249 (view as bug list)
Depends On: 912260
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 01:06 EST by Lucy Bopf
Modified: 2016-04-19 21:38 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:38:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucy Bopf 2016-01-28 01:06:17 EST
MAC address pools can now be assigned per data center in the Administration Portal, using the 'MAC Address Pool' tab of the New/Edit Data Center window. The MAC pools can also be assigned using the REST API.

MAC pools can no longer be assigned at the global level using engine-config (MacPoolRanges).
Comment 1 Lucy Bopf 2016-01-28 01:07:41 EST
Assigning to Megan for review.
Comment 6 Sharon Naftaly 2016-03-16 12:44:34 EDT
Hi,
should this bug move to ON_QA status?
Thanks.
Comment 13 Megan Lewis 2016-03-21 01:44:20 EDT
Hi Martin, 

I've finished writing the new content for the MAC address pools feature. The content I wrote for the Administration Guide is available here: http://file.bne.redhat.com/melewis/RHEV/3.6/Admin_Guide/#sect-MAC_Address_Pools and here: http://file.bne.redhat.com/melewis/RHEV/3.6/Admin_Guide/#Creating_a_New_Data_Center

The changes in the REST API Guide are available here: http://file.bne.redhat.com/melewis/RHEV/3.6/REST_API/#chap-MAC_Address_Pools and here: http://file.bne.redhat.com/melewis/RHEV/3.6/REST_API/#chap-Data_Centers

Could you please take a look let me know if you think any further changes need to be made? 

Thanks, 
Megan
Comment 14 Martin Mucha 2016-03-22 08:46:50 EDT
http://file.bne.redhat.com/melewis/RHEV/3.6/Admin_Guide/#sect-MAC_Address_Pools

• "MAC address pools allow the definition of the range of MAC addresses from which MAC addresses will be allocated for each data center." ~ MAC address pools *defines* the range of MAC addresses from which MAC addresses will be allocated. Mac pool can be specified for each individual data center.

• MAC address pools are more memory efficient when all MAC addresses assigned to a data center are within the range for the assigned MAC address pool. — MAC addresses are not assigned to data center. ~ MAC address pools are more memory efficient when all MAC addresses *related* to a data center are within the range for the assigned MAC address pool.

• The same MAC address pool can be shared by multiple data centers. Each data center must have a single MAC address pool assigned. A default MAC address pool is created by Red Hat Enterprise Virtualization and this pool is used by default if a custom MAC address pool is not assigned. — each data center has one mac pool. Always. There isn't a way (or at least shouldn't be) how to not assign pool to dc. So ~ "Each data center *has* single …". Default pool is created by system and assigned, and user can replace it with his own pool, which is not custom, only differently set, if he wants to.

• You can create new MAC address pools to control the MAC address ranges available to specific data centers. — you cannot force mac address pool to do anything else. Also ranges are not available to data center in any way. Datacenter knows only about mac address pool assigned to it, pool internals are hidden from it[dc]. ~ "You can create new MAC address pools."

• Select the Allow Duplicates check box to allow a MAC address to be used multiple times in a pool. — It may be worthy to note, that pool never use same mac on his own. Enabling this flag allows user, to use manually same MAC.

• If one MAC address pool has duplicates disabled, and another has duplicates enabled, each MAC address will only be used once in the pool with duplicates disabled but can be used multiple times in the pool with duplicates enabled. — This is not correct. ~ If one MAC address pool has duplicates disabled, and another has duplicates enabled, each MAC address *can be* be used once in the pool with duplicates disabled, but can be used multiple times in the pool with duplicates enabled.

• Click the Remove button to open the Remove Instance Type window. — shouldn't there be: Click the Remove button to open the MAC Address Pool window.





———————————————————————————
http://file.bne.redhat.com/melewis/RHEV/3.6/Admin_Guide/#Creating_a_New_Data_Center

• Optionally, set the MAC address pool for the data center. If no MAC address pool is selected the default MAC address pool is used. — It shouldn't be possible to not set pool. Default one should be preselected by UI. So user cannot not set it. User can only change it, or create new one.

———————————————————————————
http://file.bne.redhat.com/melewis/RHEV/3.6/REST_API/#chap-MAC_Address_Pools

• The name, description, allow_duplicates, default_pool, and ranges elements are updatable post-creation. — I do believe that possibility of change of default pool was removed from the system. User cannot change default pool.
Comment 15 Megan Lewis 2016-03-23 01:42:15 EDT
Hey Martin, 

Thanks so much for the comprehensive review. :) All great feedback. The changes I made are below inline with your comments. 

Thanks, 
Megan 

(In reply to Martin Mucha from comment #14)
> http://file.bne.redhat.com/melewis/RHEV/3.6/Admin_Guide/#sect-
> MAC_Address_Pools
> 
> • "MAC address pools allow the definition of the range of MAC addresses from
> which MAC addresses will be allocated for each data center." ~ MAC address
> pools *defines* the range of MAC addresses from which MAC addresses will be
> allocated. Mac pool can be specified for each individual data center.
Changed to: 
MAC address pools define the range of MAC addresses from which MAC addresses will be allocated for each data center. A MAC address pool is specified for each data center. 

> • MAC address pools are more memory efficient when all MAC addresses
> assigned to a data center are within the range for the assigned MAC address
> pool. — MAC addresses are not assigned to data center. ~ MAC address pools
> are more memory efficient when all MAC addresses *related* to a data center
> are within the range for the assigned MAC address pool.
Changed to: 
MAC address pools are more memory efficient when all MAC addresses related to a data center are within the range for the assigned MAC address pool. 

> • The same MAC address pool can be shared by multiple data centers. Each
> data center must have a single MAC address pool assigned. A default MAC
> address pool is created by Red Hat Enterprise Virtualization and this pool
> is used by default if a custom MAC address pool is not assigned. — each data
> center has one mac pool. Always. There isn't a way (or at least shouldn't
> be) how to not assign pool to dc. So ~ "Each data center *has* single …".
> Default pool is created by system and assigned, and user can replace it with
> his own pool, which is not custom, only differently set, if he wants to.
Changed to: 
Each data center has a single MAC address pool assigned. A default MAC address pool is created by Red Hat Enterprise Virtualization and this pool is used by default if another MAC address pool is not assigned.

> • You can create new MAC address pools to control the MAC address ranges
> available to specific data centers. — you cannot force mac address pool to
> do anything else. Also ranges are not available to data center in any way.
> Datacenter knows only about mac address pool assigned to it, pool internals
> are hidden from it[dc]. ~ "You can create new MAC address pools."
Changed to: 
You can create new MAC address pools. 

> • Select the Allow Duplicates check box to allow a MAC address to be used
> multiple times in a pool. — It may be worthy to note, that pool never use
> same mac on his own. Enabling this flag allows user, to use manually same
> MAC.
Changed to: 
The MAC address pool will not automatically use a duplicate MAC address but enabling the duplicates option means a user can manually use a duplicate MAC address. 

> • If one MAC address pool has duplicates disabled, and another has
> duplicates enabled, each MAC address will only be used once in the pool with
> duplicates disabled but can be used multiple times in the pool with
> duplicates enabled. — This is not correct. ~ If one MAC address pool has
> duplicates disabled, and another has duplicates enabled, each MAC address
> *can be* be used once in the pool with duplicates disabled, but can be used
> multiple times in the pool with duplicates enabled.
Changed to: 
If one MAC address pool has duplicates disabled, and another has duplicates enabled, each MAC address can be used once in the pool with duplicates disabled but can be used multiple times in the pool with duplicates enabled.

> • Click the Remove button to open the Remove Instance Type window. —
> shouldn't there be: Click the Remove button to open the MAC Address Pool
> window.
Oh whoops. Thanks so much for catching that. Changed to: 
Click the Remove button to open the Remove MAC Address Pool window.

> ———————————————————————————
> http://file.bne.redhat.com/melewis/RHEV/3.6/Admin_Guide/
> #Creating_a_New_Data_Center
> 
> • Optionally, set the MAC address pool for the data center. If no MAC
> address pool is selected the default MAC address pool is used. — It
> shouldn't be possible to not set pool. Default one should be preselected by
> UI. So user cannot not set it. User can only change it, or create new one.
Changed to: 
Optionally, change the MAC address pool for the data center. The default MAC address pool is preselected by default. 

> ———————————————————————————
> http://file.bne.redhat.com/melewis/RHEV/3.6/REST_API/#chap-MAC_Address_Pools
> 
> • The name, description, allow_duplicates, default_pool, and ranges elements
> are updatable post-creation. — I do believe that possibility of change of
> default pool was removed from the system. User cannot change default pool.
Removed default pool from the text and the example.
Comment 18 Lucy Bopf 2016-03-23 05:31:03 EDT
*** Bug 1320249 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.