Bug 1302554 - Able to create files when quota limit is set to 0
Summary: Able to create files when quota limit is set to 0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: All
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Depends On: 1294751
Blocks: 1306136
TreeView+ depends on / blocked
 
Reported: 2016-01-28 07:18 UTC by Manikandan
Modified: 2016-06-16 13:56 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1294751
: 1306136 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:56:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-01-28 07:21:21 UTC
REVIEW: http://review.gluster.org/13309 (cli/quota : quota is not enforcing when limit is set to 0) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 2 Vijay Bellur 2016-02-10 11:19:11 UTC
COMMIT: http://review.gluster.org/13309 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 32935246bf884760800029cb20627ea94a865cee
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Thu Jan 28 12:35:40 2016 +0530

    cli/quota : quota is not enforcing when limit is set to 0
    
    When limit value is set to 0, quota assumes that limit is not
    set and is not enforcing currently. The patch fixes this issue by
    restricting the user from setting limit value = 0.
    
    Change-Id: I316653165cd9766600f95b5f23e5b8abcc2b41e7
    BUG: 1302554
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13309
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 3 Niels de Vos 2016-06-16 13:56:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.