Bug 1306136 - Able to create files when quota limit is set to 0
Able to create files when quota limit is set to 0
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.7
All Unspecified
low Severity medium
: ---
: ---
Assigned To: Manikandan
: Triaged, ZStream
Depends On: 1294751 1302554
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 01:43 EST by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302554
Environment:
Last Closed: 2016-04-19 03:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-10 01:48:50 EST
REVIEW: http://review.gluster.org/13417 (cli/quota : quota is not enforcing when limit is set to 0) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2016-02-11 01:11:09 EST
COMMIT: http://review.gluster.org/13417 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit bd71d153475761de4b99bf47d90850dc7f05c4a6
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Thu Jan 28 12:35:40 2016 +0530

    cli/quota : quota is not enforcing when limit is set to 0
    
    When limit value is set to 0, quota assumes that limit is not
    set and is not enforcing currently. The patch fixes this issue by
    restricting the user from setting limit value = 0.
    
            Backport of http://review.gluster.org/#/c/13309/
    
    > Change-Id: I316653165cd9766600f95b5f23e5b8abcc2b41e7
    > BUG: 1302554
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    
    Change-Id: I83623cba54873f27bd65d5d6d85b1f8e9d895f55
    BUG: 1306136
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13417
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Kaushal 2016-04-19 03:25:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.