Bug 1302582 - The relation between memory and memory guaranteed is not consistent
The relation between memory and memory guaranteed is not consistent
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: jniederm
meital avital
:
: 1302301 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 03:32 EST by Tomas Jelinek
Modified: 2016-04-21 10:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:37:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51562 master MERGED webadmin: Consistent relation memory - guaranteed memory 2016-01-28 10:08 EST
oVirt gerrit 52921 ovirt-engine-3.6 MERGED webadmin: Consistent relation memory - guaranteed memory 2016-02-02 09:53 EST

  None (edit)
Description Tomas Jelinek 2016-01-28 03:32:36 EST
The memory guaranteed and memory size in the webadmin's new/edit dialogs is unclear.
It should behave like this in VM dialog:
- if the template is selected, it's values for memory guaranteed and min allocated memory should be copied as defined on the template
- if the user changes the memory size, the min allocated memory has to be recalculated using the overcommit regardless if the mem size is enlarged or not
Comment 1 Tomas Jelinek 2016-02-10 03:44:35 EST
*** Bug 1302301 has been marked as a duplicate of this bug. ***
Comment 2 meital avital 2016-04-11 04:55:22 EDT
Verified on:
rhevm-3.6.5.1-0.1.el6
libvirt-client-1.2.17-13.el7_2.2.x86_64
sanlock-3.2.4-1.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.10.x86_64
vdsm-4.17.25-0.el7ev.noarch


1)Create new VM from template and verify that the values of memory size and memory guaranteed are copied from the template.
1.1)Change the memory size and verify that the memory guaranteed changed to the same size.

2)Create a new VM and change the default of the memory size, verify that the memory guaranteed changed to the same value.

Note You need to log in before you can comment on or make changes to this bug.