Bug 1302772 - promotions not balanced across hot tier sub-volumes
promotions not balanced across hot tier sub-volumes
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1300679
Blocks: 1306514
  Show dependency treegraph
 
Reported: 2016-01-28 10:20 EST by Joseph Elwin Fernandes
Modified: 2016-06-16 09:56 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300679
: 1306514 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:56:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-28 10:30:21 EST
REVIEW: http://review.gluster.org/13293 (tier/gfdb : Round-Robin read of query files) posted (#4) for review on master by Joseph Fernandes
Comment 2 Vijay Bellur 2016-01-30 01:59:16 EST
REVIEW: http://review.gluster.org/13293 (tier/gfdb : Round-Robin read of query files) posted (#5) for review on master by Joseph Fernandes
Comment 3 Vijay Bellur 2016-02-01 21:47:14 EST
REVIEW: http://review.gluster.org/13293 (tier/gfdb : Round-Robin read of query files) posted (#6) for review on master by Joseph Fernandes
Comment 4 Vijay Bellur 2016-02-03 03:12:49 EST
REVIEW: http://review.gluster.org/13293 (tier/gfdb : Round-Robin read of query files) posted (#7) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 5 Vijay Bellur 2016-02-03 13:04:44 EST
COMMIT: http://review.gluster.org/13293 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 11202e6c726f79ddf0e461338d7dce158733122e
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Jan 26 17:47:08 2016 +0530

    tier/gfdb : Round-Robin read of query files
    
    1. Each brick on a host will get a separate query file.
    2. While reading query record from these query files we
       read them in a Round-Robin manner.
    3. When an error occurs during migration we rename it to
       query file with an time stamp and .err extension for
       better debugging.
    
    Change-Id: I27c4285d24fd695d2d5cbd9fd7db3879d277ecc8
    BUG: 1302772
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/13293
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: N Balachandran <nbalacha@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Niels de Vos 2016-06-16 09:56:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.