Bug 1306514 - promotions not balanced across hot tier sub-volumes
promotions not balanced across hot tier sub-volumes
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.7
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1300679 1302772
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-02-11 01:13 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302772
Environment:
Last Closed: 2016-04-19 03:25:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-11 01:17:22 EST
REVIEW: http://review.gluster.org/13427 (tier/gfdb : Round-Robin read of query files) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2016-02-14 09:27:11 EST
COMMIT: http://review.gluster.org/13427 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit d09d3406ce3eea551bd196402fdd46e3b8734bf1
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Jan 26 17:47:08 2016 +0530

    tier/gfdb : Round-Robin read of query files
    
    1. Each brick on a host will get a separate query file.
    2. While reading query record from these query files we
       read them in a Round-Robin manner.
    3. When an error occurs during migration we rename it to
       query file with an time stamp and .err extension for
       better debugging.
    
    Backport of http://review.gluster.org/13293
    
    > Change-Id: I27c4285d24fd695d2d5cbd9fd7db3879d277ecc8
    > BUG: 1302772
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/13293
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: N Balachandran <nbalacha@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: I9448f19c10a82fff9b1b3c9387c9026adc0742f1
    BUG: 1306514
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/13427
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:25:16 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.