Bug 1302812 - backport the metadata_cache_expiration config option to avoid hardcoded value of 15s
backport the metadata_cache_expiration config option to avoid hardcoded value...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
unspecified Severity unspecified
: async
: 6.0 (Juno)
Assigned To: Sven Anderson
Prasanth Anbalagan
: ZStream
: 1302813 (view as bug list)
Depends On: 1302401
Blocks: 1302811
  Show dependency treegraph
 
Reported: 2016-01-28 11:54 EST by Sven Anderson
Modified: 2016-02-22 07:34 EST (History)
12 users (show)

See Also:
Fixed In Version: openstack-nova-2014.2.3-54.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302401
Environment:
Last Closed: 2016-02-22 07:34:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Nova startup logs (48.80 KB, text/plain)
2016-02-03 16:36 EST, Prasanth Anbalagan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1366139 None None None 2016-01-28 11:54 EST
OpenStack gerrit 159264 None None None 2016-01-28 11:54 EST

  None (edit)
Comment 1 Sven Anderson 2016-02-01 08:48:33 EST
*** Bug 1302813 has been marked as a duplicate of this bug. ***
Comment 4 Prasanth Anbalagan 2016-02-03 16:36 EST
Created attachment 1120911 [details]
Nova startup logs
Comment 5 Prasanth Anbalagan 2016-02-03 16:37:48 EST
Verified as follows - No error observed during nova startup with the option metadata_cache_expiration defined in /etc/nova/nova.conf.

************
Version
************

[root@a-b-c-d nova(keystone_admin)]# yum list installed | grep openstack-nova
openstack-nova-api.noarch            2014.2.3-54.el7ost      @rhelosp-6.0-puddle
openstack-nova-cert.noarch           2014.2.3-54.el7ost      @rhelosp-6.0-puddle
openstack-nova-common.noarch         2014.2.3-54.el7ost      @rhelosp-6.0-puddle
openstack-nova-compute.noarch        2014.2.3-54.el7ost      @rhelosp-6.0-puddle
openstack-nova-conductor.noarch      2014.2.3-54.el7ost      @rhelosp-6.0-puddle
openstack-nova-console.noarch        2014.2.3-54.el7ost      @rhelosp-6.0-puddle
openstack-nova-novncproxy.noarch     2014.2.3-54.el7ost      @rhelosp-6.0-puddle
openstack-nova-scheduler.noarch      2014.2.3-54.el7ost      @rhelosp-6.0-puddle
[root@a-b-c-d nova(keystone_admin)]# 


********
Logs
********
[root@a-b-c-d nova(keystone_admin)]# grep "metadata_cache" /etc/nova/nova.conf 
metadata_cache_expiration = 15
[root@a-b-c-d nova(keystone_admin)]# 

[root@a-b-c-d nova(keystone_admin)]# openstack-service restart nova

P.S: Nova startup logs has been attached as nova-startup-logs.txt
Comment 7 errata-xmlrpc 2016-02-22 07:34:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0283.html

Note You need to log in before you can comment on or make changes to this bug.