Bug 1302813 - backport the metadata_cache_expiration config option to avoid harcoded value of 15s
backport the metadata_cache_expiration config option to avoid harcoded value ...
Status: CLOSED DUPLICATE of bug 1302812
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 6.0 (Juno)
Assigned To: Sven Anderson
nlevinki
: ZStream
Depends On: 1302401
Blocks: 1302811
  Show dependency treegraph
 
Reported: 2016-01-28 11:54 EST by Sven Anderson
Modified: 2016-02-01 08:48 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302401
Environment:
Last Closed: 2016-02-01 08:48:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1366139 None None None 2016-01-28 11:54 EST
OpenStack gerrit 159264 None None None 2016-01-28 11:54 EST

  None (edit)
Description Sven Anderson 2016-01-28 11:54:14 EST
+++ This bug was initially created as a clone of Bug #1302401 +++

The metadata cache expiration timeout was hardcoded to 15 seconds in versions older than kilo (OSP7).

In kilo a new configuration option was added:

  'metadata_cache_expiration',

  Time in seconds to cache metadata; 0 to disable
  metadata caching entirely (not recommended). Increasing
  this should improve response times of the metadata API
  when under heavy load. Higher values may increase memory
  usage and result in longer times for host metadata
  changes to take effect.

introduced in:

  https://review.openstack.org/159264

This config option should be backported to OSP5 in order to provide the same flexibility and avoid premature cache expiration in cases where the metadata is highly static.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-01-27 13:30:20 EST ---

Since this issue was entered in bugzilla without a release flag set, rhos-8.0? has been automatically added to ensure that it is properly evaluated for this release.
Comment 1 Sven Anderson 2016-02-01 08:48:33 EST

*** This bug has been marked as a duplicate of bug 1302812 ***

Note You need to log in before you can comment on or make changes to this bug.