Bug 1302831 - Hooks can remain set after a stack operation is stopped
Hooks can remain set after a stack operation is stopped
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Zane Bitter
Amit Ugol
:
Depends On: 1302828 1309817
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-28 13:12 EST by Zane Bitter
Modified: 2016-04-26 16:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-heat-5.0.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302828
Environment:
Last Closed: 2016-04-07 17:26:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1538733 None None None 2016-01-28 13:12 EST
OpenStack gerrit 273662 None None None 2016-02-25 21:51 EST

  None (edit)
Description Zane Bitter 2016-01-28 13:12:24 EST
+++ This bug was initially created as a clone of Bug #1302828 +++

If a thread is cancelled (including if heat-engine is restarted) while a user hook (aka breakpoint) is active, the hook is still marked as active in the database. If the user modifies the environment to disable the hook, then the next time Heat reaches the point in traversing the stack where the hook was invoked Heat will pause and wait for the hook to be cleared; however there will be no log message to indicate that the hook was invoked, nor a corresponding event in the event list, nor any indication from the "hook-poll" command that the hook is active.

A simple workaround exists: just clear the hooks and everything will proceed. However, the problem is almost impossible to diagnose.
Comment 3 errata-xmlrpc 2016-04-07 17:26:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.