Bug 1309817 - Hooks can remain set after a stack operation is stopped
Hooks can remain set after a stack operation is stopped
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: async
: 7.0 (Kilo)
Assigned To: Zane Bitter
Amit Ugol
: TestOnly, ZStream
Depends On: 1302828
Blocks: 1302831
  Show dependency treegraph
 
Reported: 2016-02-18 13:46 EST by Scott Lewis
Modified: 2016-09-28 15:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302828
Environment:
Last Closed: 2016-09-28 15:27:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1538733 None None None 2016-02-18 13:46 EST

  None (edit)
Comment 3 Zane Bitter 2016-03-10 09:28:39 EST
This should be fairly easy to reproduce with a simple stack (only one resource required).

- set a pre-update hook on a resource
- start a stack update
- wait for the workflow to reach the hook and pause
- restart heat-engine while heat is still waiting for the hook
- do another stack update, removing the pre-update hook from the environment (so that this update should not stop for the hook)
- ensure that the update completes

Previously, the last update would stop at the hook (even though it wasn't requested in the environment), although you couldn't tell that because nothing appeared in the events or 'heat hook-poll'.

Note You need to log in before you can comment on or make changes to this bug.