Bug 1302851 - smart state error "Unable to mount filesystem. Reason:[No root filesystem found.]"
smart state error "Unable to mount filesystem. Reason:[No root filesystem fo...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Hui Song
Niyaz Akhtar Ansari
vsphere:vm:smartstate
: ZStream
: 1297022 (view as bug list)
Depends On:
Blocks: 1306416 1430356
  Show dependency treegraph
 
Reported: 2016-01-28 14:05 EST by Josh Carter
Modified: 2017-03-08 07:43 EST (History)
13 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1306416 1430356 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:34:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Carter 2016-01-28 14:05:26 EST
Description of problem:

VCenter 6.0
vix vddk 6.0.1

The appliance is able to smart state itself which also resides on the same vcenter as the other guest that are unable to be scanned. 

The guest systems that raise the "No root filesystem found" are Rhel 7 guest 
with EXT4 filesytem that is spread across 3 disk. Normally / is on one disk, /swap is on a second and then user directories is on a third.

[----] I, [2016-01-22T14:57:06.661604 #3031:ff5988]  INFO -- : Q-task_id([3578e126-c142-11e5-b7be-005056a6315c]) MIQ(MiqQueue.put) Message id: [404000000281776],  id: [], Zone: [
default], Role: [automate], Server: [], Ident: [generic], Target id: [], Instance id: [], Task id: [], Command: [MiqAeEngine.deliver], Timeout: [3600], Priority: [20], State: [re
ady], Deliver On: [], Data: [], Args: [{:object_type=>"ManageIQ::Providers::Vmware::InfraManager::Vm", :object_id=>404000000000505, :attrs=>{:event_type=>"vm_scan_abort", "VmOrTe
mplate::vm"=>404000000000505, :vm_id=>404000000000505, "Host::host"=>404000000000001, :host_id=>404000000000001, "MiqEvent::miq_event"=>404000000005880, :miq_event_id=>404000000005880, "EventStream::event_stream"=>404000000005880, :event_stream_id=>404000000005880}, :instance_name=>"Event", :user_id=>404000000000002, :miq_group_id=>404000000000017, :tenant_id=>404000000000001, :automate_message=>nil}]
[----] E, [2016-01-22T14:57:06.661711 #3031:ff5988] ERROR -- : Q-task_id([3578e126-c142-11e5-b7be-005056a6315c]) MIQ(VmScan#process_abort) job aborting, Unable to mount filesystem.  Reason:[No root filesystem found.]
[----] I, [2016-01-22T14:57:06.678714 #3031:ff5988]  INFO -- : Q-task_id([3578e126-c142-11e5-b7be-005056a6315c]) MIQ(VmScan#process_finished) job finished, Unable to mount filesystem.  Reason:[No root filesystem found.]


Version-Release number of selected component (if applicable): 5.5.0


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Shveta 2016-02-01 16:32:52 EST
Assigning to add test case
Comment 26 Rich Oliveri 2016-03-02 11:59:38 EST
*** Bug 1297022 has been marked as a duplicate of this bug. ***
Comment 39 Niyaz Akhtar Ansari 2016-05-04 06:27:40 EDT
Hi Hui,

Please add verification steps.

Thanks
Comment 40 Hui Song 2016-05-04 09:07:04 EDT
This issue only happens when the root filesystem is ext4 and group descriptor size is 64:

1. Use RHEL-Server automated installer (Comment 21) to create a VM. The created VM should meet the above conditions.
2. Use command mount to verify the root filesystem is ext4.
3. Use command dumpe2fs to verify the group descriptor size (Comment 20).
4. Verify the fix
Comment 41 Niyaz Akhtar Ansari 2016-05-25 14:18:54 EDT
Hi Colin,

Can you please provide more details around the automated install configuration like the kickstart file itself? 

Thanks
Comment 44 Niyaz Akhtar Ansari 2016-06-20 04:59:43 EDT
Created a VM with root filesystem ext4 and group descriptor size 64,
SmartState Analysis  Works Successfully. 

Verified in 5.6.0.11-rc2.2.20160614152915_f315c68
Comment 46 errata-xmlrpc 2016-06-29 11:34:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.