Bug 1306416 - smart state error "Unable to mount filesystem. Reason:[No root filesystem found.]"
smart state error "Unable to mount filesystem. Reason:[No root filesystem fo...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.5.3
Assigned To: Hui Song
Dave Johnson
vsphere:vm:smartstate
: ZStream
Depends On: 1302851 1430356
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 14:12 EST by John Prause
Modified: 2017-08-29 22:04 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Previously, there was a SmartState error, "Unable to mount filesystem. Reason:[No root filesystem found.]” The issue was caused because the internal structure of the filesystem used 64 bit group descriptors. This patch changes the logic to decide the size of group descriptor based on INCOMPAT_64BIT flag and s_desc_size from superblock. As a result, the issue is now resolved and SmartState analysis is successful.
Story Points: ---
Clone Of: 1302851
Environment:
Last Closed: 2016-04-13 14:43:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0616 normal SHIPPED_LIVE CFME 5.5.3 bug fixes and enhancement update 2016-04-13 18:38:44 EDT

  None (edit)
Comment 1 Rich Oliveri 2016-03-21 10:16:48 EDT
Marianne,

The problem isn't really related to the fact that the filesystem is spread across 3 disks. It just happened that the internal structure of the FS used 64 bit group descriptors.
Comment 4 errata-xmlrpc 2016-04-13 14:43:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.