Bug 1302955 - Hook scripts are not installed after make install
Hook scripts are not installed after make install
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
3.7.7
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1174765
Blocks: 1171477 1293708
  Show dependency treegraph
 
Reported: 2016-01-29 01:34 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1174765
Environment:
Last Closed: 2016-04-19 03:41:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2016-01-29 01:34:01 EST
+++ This bug was initially created as a clone of Bug #1174765 +++

+++ This bug was initially created as a clone of Bug #1171477 +++

Description of problem:
When GLusterFS is built from source, the hook scripts are not copied over to /var/lib/glusterd/hooks as part of the install make target.

Version-Release number of selected component (if applicable):
3.5.3

How reproducible:
5 times on 5 makes of Gluster on CentOS 6.4

Steps to Reproduce:
1. Download source and build
2. Observe that directories are created in /var/lib/glusterd/hooks, but hook scripts are not copied over

Actual results:
Hook scripts are not present in hooks directories

Expected results:
Hook scripts should be present in hooks directories after running make install

Additional info:
Attaching directory listings for the hooks directory post-install and in the source folder.

--- Additional comment from David Gibbons on 2014-12-07 16:24:06 CET ---



--- Additional comment from Niels de Vos on 2014-12-16 13:49:13 CET ---

The hook scripts are manually installed in the glusterfs.spec. It is much better to install these scripts when "make install" is run. This would make it much more common user experience on all distributions and manual installations.

--- Additional comment from Vijay Bellur on 2015-12-23 08:05:00 EST ---

REVIEW: http://review.gluster.org/13072 (build: use 'make install' to install the hook scripts) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-26 12:31:39 EST ---

COMMIT: http://review.gluster.org/13072 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 7ab8a1a3f4510a284b1686302624ec4252c95a6f
Author: Niels de Vos <ndevos@redhat.com>
Date:   Wed Dec 23 13:57:14 2015 +0100

    build: use 'make install' to install the hook scripts
    
    The installation should be the same on all distributions, and doing
    manual installation of files in the .spec is very ugly. This change adds
    the rules so that 'make install' places the hook scripts in the right
    location.
    
    Also, the hook script(s) for NFS-Ganesha should be part of the
    glusterfs-ganesha sub-package and got moved there.
    
    BUG: 1174765
    Change-Id: Iba25a7a5112c7d40db4c10ff4a5ac7a5fb4f7c4e
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/13072
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

--- Additional comment from Kaleb KEITHLEY on 2015-12-28 07:23:56 EST ---



--- Additional comment from Kaleb KEITHLEY on 2015-12-28 07:25:22 EST ---
Comment 1 Vijay Bellur 2016-01-29 02:03:12 EST
REVIEW: http://review.gluster.org/13313 (build: use 'make install' to install the hook scripts) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-02-04 01:11:13 EST
COMMIT: http://review.gluster.org/13313 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 61c2aec3034714e513bcc3ad9ea61c2bb63b07fe
Author: vmallika <vmallika@redhat.com>
Date:   Fri Jan 29 12:20:59 2016 +0530

    build: use 'make install' to install the hook scripts
    
    This is a backport of http://review.gluster.org/#/c/13072
    
    The installation should be the same on all distributions, and doing
    manual installation of files in the .spec is very ugly. This change adds
    the rules so that 'make install' places the hook scripts in the right
    location.
    
    Also, the hook script(s) for NFS-Ganesha should be part of the
    glusterfs-ganesha sub-package and got moved there.
    
    > BUG: 1174765
    > Change-Id: Iba25a7a5112c7d40db4c10ff4a5ac7a5fb4f7c4e
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: http://review.gluster.org/13072
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    
    Change-Id: I8fade7e9e540eedc1e619f116d356a2b26f599a9
    BUG: 1302955
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13313
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 3 Kaushal 2016-04-19 03:41:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.8, please open a new bug report.

glusterfs-3.7.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.