Bug 1303037 - portblock resource-agent
portblock resource-agent
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.3
All All
unspecified Severity medium
: rc
: ---
Assigned To: Oyvind Albrigtsen
cluster-qe@redhat.com
:
Depends On: 1302545 1337109
Blocks: 1330218 1363722 1278336 1354439
  Show dependency treegraph
 
Reported: 2016-01-29 06:44 EST by Oyvind Albrigtsen
Modified: 2016-11-03 20:01 EDT (History)
11 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-82.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302545
Environment:
Last Closed: 2016-11-03 20:01:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Oyvind Albrigtsen 2016-01-29 07:34:04 EST
Tested resource agent from upstream and verified that it's working on RHEL7.
Comment 4 Oyvind Albrigtsen 2016-02-22 07:08:40 EST
The easiest example would be to simply block one of the ports for a service:
# pcs resource create VIP IPaddr2 ip=192.168.122.122
# pcs resource create pb ocf:heartbeat:portblock protocol=tcp portno=3306 action=block ip=192.168.122.122
# pcs resource create NFS nfsserver
# pcs resource group add NFS-group VIP pb NFS
# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
DROP       tcp  --  anywhere             HOSTNAME              multiport dports mysql

I'm using a MySQL port in this example to avoid NFS failing.
Comment 9 Oyvind Albrigtsen 2016-09-16 05:17:16 EDT
Tested and working patch: https://github.com/ClusterLabs/resource-agents/pull/845
Comment 13 errata-xmlrpc 2016-11-03 20:01:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2174.html

Note You need to log in before you can comment on or make changes to this bug.