Bug 1303150 - [RFE] Provide a Python SDK for API consumption
[RFE] Provide a Python SDK for API consumption
Status: NEW
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.1.6
All Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks: 1317530
  Show dependency treegraph
 
Reported: 2016-01-29 11:56 EST by Julio Entrena Perez
Modified: 2017-02-16 11:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2751881 None None None 2016-11-06 08:50 EST

  None (edit)
Description Julio Entrena Perez 2016-01-29 11:56:01 EST
1. Proposed title of this feature request  
Provide a Python SDK for API consumption
  
3. What is the nature and description of the request?
A Python SDK should be provided, documented and supported for easier consumption of the Satellite 6 API in Python.
A Python SDK is already available for RHEV, this request is about providing equivalent SDK covering the Satellite 6 API.
  
4. Why does the customer need this? (List the business requirements here)
To facilitate the consumption of the Satellite 6 API in Python code.
  
5. How would the customer like to achieve this? (List the functional requirements here)  
- A Python SDK for Satellite 6 is provided.
- The Python SDK provides the same level of functionality that is currently available in the REST API.
- The Python SDK is properly documented.

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
- The Python SDK can be downloaded and installed.
- The Python SDK provides methods for all the currently available API calls and supports all options already available.
- The documentation for Python SDK can be downloaded or reviewed online and covers all aspects of the SDK.
  
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
Somewhat related bug 1266580 (closed as wontfix).
  
8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
Satellite 6.3.
  
9. Is the sales team involved in this request and do they have any additional input?  
Yes.
  
10. List any affected packages or components.
N/A
  
11. Would the customer be able to assist in testing this functionality if implemented?
Yes.
Comment 2 Bryan Kearney 2016-01-30 08:30:09 EST
Would https://github.com/SatelliteQE/nailgun/ meet your needs?
Comment 4 Xixi 2016-02-10 18:49:05 EST
possible duplicate of Bug 1266580 - [RFE] python API to interact with hammer
Comment 5 Bryan Kearney 2016-02-11 11:51:20 EST
Lets try to deliver nailgun as part of 6.3
Comment 7 Bryan Kearney 2016-07-08 16:40:08 EDT
Per 6.3 planning, moving out non acked bugs to the backlog

Note You need to log in before you can comment on or make changes to this bug.