Bug 1303161 - crontab entry creating multiple emails
crontab entry creating multiple emails
Status: CLOSED DUPLICATE of bug 1412697
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Shlomi Zadok
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Reopened, Triaged
Depends On:
Blocks: 1412697
  Show dependency treegraph
 
Reported: 2016-01-29 13:11 EST by Shane Ellerthorpe
Modified: 2017-01-12 10:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1412697 (view as bug list)
Environment:
Last Closed: 2017-01-12 10:17:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13487 None None None 2016-04-22 10:58 EDT

  None (edit)
Description Shane Ellerthorpe 2016-01-29 13:11:07 EST
Description of problem:
The crontab that is created for scap reporting generates an email even when nothing is wrong. This causes a larger issue on big environments. I'd like to see the STDOUT be redirected to /dev/null, and only STDERR generating an email.

Version-Release number of selected component (if applicable):
All

How reproducible:
This is standard behavior. This is a feature change more than a bug report

Steps to Reproduce:
1. install from RPM
2. Schedule a scan
3. verify crontab on remote system

Actual results:
An email is sent containing the STDOUT form the crontab to the root user

Expected results:
The system should only email when there is an issue with the crontab, not during normal processing.

Additional info:
https://github.com/theforeman/puppet-foreman_scap_client/pull/13 covers this change, however it was never implemented. You can modify the /usr/share/puppet/modules/foreman_scap_client/manifests/init.pp file by hand, however any new RPM upgrade will override that change.
Comment 1 Bryan Kearney 2016-01-31 08:02:09 EST
Created redmine issue http://projects.theforeman.org/issues/13487 from this bug
Comment 2 Bryan Kearney 2016-02-18 08:04:27 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13487 has been closed
-------------
Shlomi Zadok
Merged as https://github.com/theforeman/puppet-foreman_scap_client/commit/3df2fa5e1a79f3b2880ea2ae8b02cfe736e9301a
Comment 6 Kedar Bidarkar 2016-04-20 09:55:26 EDT
I do not see this change in /usr/share/puppet/modules/foreman_scap_client/manifests/init.pp


~]# rpm -qav | grep -i puppet-foreman_scap
puppet-foreman_scap_client-0.3.3-10.el7sat.noarch


TESTED with sat62-snap8.1
Comment 9 errata-xmlrpc 2016-07-27 05:22:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501
Comment 11 Kedar Bidarkar 2017-01-12 10:17:36 EST

*** This bug has been marked as a duplicate of bug 1412697 ***

Note You need to log in before you can comment on or make changes to this bug.