Bug 1303332 - AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'
AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'
Status: CLOSED DUPLICATE of bug 1297905
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:8dc3fb0d022ad0372ba04f33105...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-30 18:10 EST by Noel McLoughlin
Modified: 2016-01-31 08:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1303334 (view as bug list)
Environment:
Hypervisor process for VM: <posixuser> 3809 1 43 22:43 ? 00:13:16 qemu-system-x86_64 -enable-kvm -name f24rawhide -S -machine pc-i440fx-trusty,accel=kvm,usb=off -bios OVMF.fd -m 1024 -smp 1,sockets=1,cores=1,threads=1 -uuid 559e3934-ff4e-b613-4d9d-5029d57ab943 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/f24rawhide.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot c -usb -drive file=/var/lib/libvirt/images/f24rawhide.img,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/home/enoemcl/workspace/ISO/Fedora-Live-Workstation-x86_64-rawhide-20160129.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=25,id=hostnet0,vhost=on,vhostfd=26 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:c8:f1:fe,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -vnc 127.0.0.1:1 -vga qxl -global qxl.ram_size=67108864 -global qxl.vram_size=67108864 -device AC97,id=sound0,bus=pci.0,addr=0x4 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
Last Closed: 2016-01-31 08:44:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.04 MB, text/plain)
2016-01-30 18:10 EST, Noel McLoughlin
no flags Details
File: anaconda.log (54.48 KB, text/plain)
2016-01-30 18:10 EST, Noel McLoughlin
no flags Details
File: environ (494 bytes, text/plain)
2016-01-30 18:10 EST, Noel McLoughlin
no flags Details
File: journalctl (581.48 KB, text/plain)
2016-01-30 18:11 EST, Noel McLoughlin
no flags Details
File: lsblk_output (2.02 KB, text/plain)
2016-01-30 18:11 EST, Noel McLoughlin
no flags Details
File: nmcli_dev_list (2.12 KB, text/plain)
2016-01-30 18:11 EST, Noel McLoughlin
no flags Details
File: os_info (528 bytes, text/plain)
2016-01-30 18:11 EST, Noel McLoughlin
no flags Details
File: program.log (27.39 KB, text/plain)
2016-01-30 18:11 EST, Noel McLoughlin
no flags Details
File: storage.log (328.29 KB, text/plain)
2016-01-30 18:11 EST, Noel McLoughlin
no flags Details
File: ifcfg.log (4.22 KB, text/plain)
2016-01-30 18:11 EST, Noel McLoughlin
no flags Details
Screenshot of Error dialog (117.50 KB, image/png)
2016-01-30 18:13 EST, Noel McLoughlin
noel.mcloughlin: review-
Details
Screenshot of Error dialog 2 (133.28 KB, image/png)
2016-01-30 18:18 EST, Noel McLoughlin
noel.mcloughlin: review-
Details
anaconda-2016-01-30-23:30:46.555124-4018.tar.gz (492.68 KB, application/octet-stream)
2016-01-30 18:38 EST, Noel McLoughlin
noel.mcloughlin: review-
Details

  None (edit)
Description Noel McLoughlin 2016-01-30 18:10:27 EST
Description of problem:

1. Launch Rawhide Live DVD installer
2. Choose Install to Disk
3. Proceed to Custom partitioning screen
(a) Make some changes (i.e. /boot and /boot/efi and / partition sizes)
(b) Choose [Done] and review "SUMMARY OF CHANGES"
(c) Choose [Cancel & Return to manual partitioning] button instead of [Accept Changes]



Version-Release number of selected component:
anaconda-core-24.9-1.fc24.x86_64

The following was filed automatically by anaconda:
anaconda 24.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/lib/space.py", line 80, in check
    dev_required_size = self.payload.requiredDeviceSize(self.storage.rootDevice.format)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 238, in _updateContinue
    if self._checker and not self._checker.check():
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 233, in _handleCompleteness
    self._updateContinue()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 219, in _updateCompleteness
    self._handleCompleteness(spoke, update_continue)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 288, in _update_spokes
    self._updateCompleteness(spoke)
AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-rawhide-20 ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.0-0.rc1.git0.2.fc24.x86_64
other involved packages: anaconda-gui-24.9-1.fc24.x86_64
product:        Fedora
release:        Fedora release 24 (Rawhide)
type:           anaconda
version:        rawhide
Comment 1 Noel McLoughlin 2016-01-30 18:10:53 EST
Created attachment 1119679 [details]
File: anaconda-tb
Comment 2 Noel McLoughlin 2016-01-30 18:10:55 EST
Created attachment 1119680 [details]
File: anaconda.log
Comment 3 Noel McLoughlin 2016-01-30 18:10:57 EST
Created attachment 1119681 [details]
File: environ
Comment 4 Noel McLoughlin 2016-01-30 18:11:11 EST
Created attachment 1119682 [details]
File: journalctl
Comment 5 Noel McLoughlin 2016-01-30 18:11:12 EST
Created attachment 1119683 [details]
File: lsblk_output
Comment 6 Noel McLoughlin 2016-01-30 18:11:14 EST
Created attachment 1119684 [details]
File: nmcli_dev_list
Comment 7 Noel McLoughlin 2016-01-30 18:11:15 EST
Created attachment 1119685 [details]
File: os_info
Comment 8 Noel McLoughlin 2016-01-30 18:11:17 EST
Created attachment 1119686 [details]
File: program.log
Comment 9 Noel McLoughlin 2016-01-30 18:11:25 EST
Created attachment 1119687 [details]
File: storage.log
Comment 10 Noel McLoughlin 2016-01-30 18:11:27 EST
Created attachment 1119688 [details]
File: ifcfg.log
Comment 11 Noel McLoughlin 2016-01-30 18:13 EST
Created attachment 1119689 [details]
Screenshot of Error dialog
Comment 12 Noel McLoughlin 2016-01-30 18:18 EST
Created attachment 1119690 [details]
Screenshot of Error dialog 2
Comment 13 Noel McLoughlin 2016-01-30 18:20:44 EST
Forced to select [Quit] and restart installer
Comment 14 Noel McLoughlin 2016-01-30 18:38 EST
Created attachment 1119703 [details]
anaconda-2016-01-30-23:30:46.555124-4018.tar.gz

Replicated immediately, see attachment anaconda-2016-01-30-23:30:46.555124-4018.tar.gz.  Bug in custom partitioning.
Comment 15 Noel McLoughlin 2016-01-31 08:43:55 EST
Fixed in anaconda 24.10 
Tested Fedora-Live-Workstation-x86_64-rawhide-20160131.iso
Comment 16 Noel McLoughlin 2016-01-31 08:44:15 EST

*** This bug has been marked as a duplicate of bug 1297905 ***

Note You need to log in before you can comment on or make changes to this bug.