Bug 1297905 - AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'
AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:8b1001e21cec6c2ddfe156c906d...
:
: 1303332 1304589 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 13:09 EST by lea89
Modified: 2016-02-08 14:00 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-24.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 03:43:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.68 MB, text/plain)
2016-01-12 13:11 EST, lea89
no flags Details
File: anaconda.log (14.22 KB, text/plain)
2016-01-12 13:11 EST, lea89
no flags Details
File: environ (494 bytes, text/plain)
2016-01-12 13:11 EST, lea89
no flags Details
File: journalctl (789.87 KB, text/plain)
2016-01-12 13:11 EST, lea89
no flags Details
File: lsblk_output (3.15 KB, text/plain)
2016-01-12 13:11 EST, lea89
no flags Details
File: lvm.log (551.85 KB, text/plain)
2016-01-12 13:12 EST, lea89
no flags Details
File: nmcli_dev_list (2.44 KB, text/plain)
2016-01-12 13:12 EST, lea89
no flags Details
File: os_info (528 bytes, text/plain)
2016-01-12 13:12 EST, lea89
no flags Details
File: program.log (77.08 KB, text/plain)
2016-01-12 13:12 EST, lea89
no flags Details
File: storage.log (232.45 KB, text/plain)
2016-01-12 13:12 EST, lea89
no flags Details
File: ifcfg.log (4.24 KB, text/plain)
2016-01-12 13:12 EST, lea89
no flags Details
File: Screenshot from 2016-01-12 13-04-53.png (107.65 KB, application/octet-stream)
2016-01-12 13:12 EST, lea89
no flags Details
Screenshot of Error dialog (after reporting error) (84.56 KB, image/png)
2016-01-30 19:09 EST, Noel McLoughlin
no flags Details

  None (edit)
Description lea89 2016-01-12 13:09:09 EST
Description of problem:
El problema surgue cuando se selecciona el destino de la instalación. Al configurar el particionamiento de manera automática se genera el error. 

Version-Release number of selected component:
anaconda-core-24.9-1.fc24.x86_64

The following was filed automatically by anaconda:
anaconda 24.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 88, in __init__
    required_dev_size = self.payload.requiredDeviceSize(FS.biggestOverheadFS())
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 848, in _run_dialogs
    resize_dialog = ResizeDialog(self.data, self.storage, self.payload)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 969, in on_back_clicked
    rc = self._run_dialogs(disks, start_with=dialog)
AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-rawhide-20 ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.4.0-0.rc8.git3.1.fc24.x86_64
other involved packages: anaconda-gui-24.9-1.fc24.x86_64
product:        Fedora
release:        Fedora release 24 (Rawhide)
type:           anaconda
version:        rawhide
Comment 1 lea89 2016-01-12 13:11:09 EST
Created attachment 1114059 [details]
File: anaconda-tb
Comment 2 lea89 2016-01-12 13:11:12 EST
Created attachment 1114060 [details]
File: anaconda.log
Comment 3 lea89 2016-01-12 13:11:14 EST
Created attachment 1114061 [details]
File: environ
Comment 4 lea89 2016-01-12 13:11:49 EST
Created attachment 1114062 [details]
File: journalctl
Comment 5 lea89 2016-01-12 13:11:51 EST
Created attachment 1114063 [details]
File: lsblk_output
Comment 6 lea89 2016-01-12 13:12:19 EST
Created attachment 1114064 [details]
File: lvm.log
Comment 7 lea89 2016-01-12 13:12:21 EST
Created attachment 1114065 [details]
File: nmcli_dev_list
Comment 8 lea89 2016-01-12 13:12:23 EST
Created attachment 1114066 [details]
File: os_info
Comment 9 lea89 2016-01-12 13:12:27 EST
Created attachment 1114067 [details]
File: program.log
Comment 10 lea89 2016-01-12 13:12:33 EST
Created attachment 1114068 [details]
File: storage.log
Comment 11 lea89 2016-01-12 13:12:35 EST
Created attachment 1114069 [details]
File: ifcfg.log
Comment 12 lea89 2016-01-12 13:12:39 EST
Created attachment 1114070 [details]
File: Screenshot from 2016-01-12 13-04-53.png
Comment 14 Adam Williamson 2016-01-18 14:41:53 EST
Another user experienced a similar problem:

Booted 2016-01-18 Rawhide nightly Workstation live image, ran the insaller, went to INSTALLATION DESTINATION, clicked Done (the single virtIO disk attached to the VM was selection), INSTALLATION OPTIONS popped up as the disk is full, hit 'Reclaim space', crash.

The disk contains an existing Fedora install, can't recall the exact details of that install, probably another Rawhide install from a recent nightly.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-rawhide-20 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.5.0-0.rc0.git1.1.fc24.x86_64
other involved packages: anaconda-gui-24.9-1.fc24.x86_64
package:        anaconda-core-24.9-1.fc24.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'
release:        Fedora release 24 (Rawhide)
version:        rawhide
Comment 15 Noel McLoughlin 2016-01-30 19:06:23 EST
Another user experienced a similar problem:


1. Lunch rawhide live DVD 
2. Start "Install to Disk"
3. Select Partitioning
4. Select [Done] without making any modifications or taking any actions.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-rawhide-20 ro rd.live.image quiet rhgb rd.live.check
hashmarkername: anaconda
kernel:         4.5.0-0.rc1.git0.2.fc24.x86_64
other involved packages: anaconda-gui-24.9-1.fc24.x86_64
package:        anaconda-core-24.9-1.fc24.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'
release:        Fedora release 24 (Rawhide)
version:        rawhide
Comment 16 Noel McLoughlin 2016-01-30 19:09 EST
Created attachment 1119704 [details]
Screenshot of Error dialog (after reporting error)
Comment 17 Noel McLoughlin 2016-01-30 19:30:39 EST
Started again. Increased disk image size to 8GB from 5GB.  During anaconda "install to disk" phase I entered/exited partitioning without making any modifications & Selections and issue not reproduced.  Was able to [Begin Installation] of Rawhide with no crash.
Comment 18 Adam Williamson 2016-01-30 20:09:37 EST
This bug's already believed to be fixed in anaconda 24.10, but you were testing with an image with 24.9.
Comment 19 Noel McLoughlin 2016-01-31 07:19:50 EST
ok, thanks for pointing this out, will retest with later image.
Comment 20 Noel McLoughlin 2016-01-31 08:42:05 EST
Yes. Fixed in anaconda 24.10 
Tested Fedora-Live-Workstation-x86_64-rawhide-20160131.iso
Comment 21 Noel McLoughlin 2016-01-31 08:44:15 EST
*** Bug 1303332 has been marked as a duplicate of this bug. ***
Comment 22 Adam Williamson 2016-02-01 03:43:58 EST
Thanks for confirming the fix!
Comment 23 Chris Murphy 2016-02-03 22:19:03 EST
Another user experienced a similar problem:

1. Autopartitioning path
2. Clicked on Reclaim Space button
crash

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-rawhide-20 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.5.0-0.rc0.git9.1.fc24.x86_64
other involved packages: anaconda-gui-24.9-1.fc24.x86_64
package:        anaconda-core-24.9-1.fc24.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'LiveImagePayload' object has no attribute 'requiredDeviceSize'
release:        Fedora release 24 (Rawhide)
version:        rawhide
Comment 24 David Shea 2016-02-08 14:00:43 EST
*** Bug 1304589 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.